cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
leyburn19
Memorable Member
Memorable Member

Is this a bug?

I have a powerapp that I want to initiate a flow.  I have the flow do a number (4) of "Ask in powerapps" statements.  One of these is linked to Sharepoint Get Items where the Filter Query looks for items based on what I pass from powerapps.  The problem I have is that when I save this request the powerapps piece just dissappears.  No matter what I do this part of the flow never appears in the powerapps fuction to populate. It also disaapears from te dynamic list yet still appears in the query box - totally wierd action

 

All others are there. Does anybody know why.  Image attached.  Note in this image the before and after ' is removed,  but  I have tried with or without.  

 

Capture.png

 

 

2 REPLIES 2
v-yamao-msft
Community Support
Community Support

Hi @leyburn19,

 

From the screenshot, I know that the flow is asking dynamic contents from PowerApps. However, it seems that when adding the flow on a PowerApps button, the request just disappears.

However, the issue could not be reproduced when testing it on my side.

I have made a flow likes below which is triggered by a PowerApps button, and then get filtered items from SharePoint list.

Note: in the action Get items, please make sure surround a single quote on the dynamic content.

1.PNG

When I tried adding the flow on a PowerApps button, no issue occurred.

2.PNG

Could you take another try with it?

If you are still having the issue, please feel free post back. 

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Unfortunately I tried everything - but would not fix.  Maybe the environment - eg: using Chrome and I started creating the flow from within powerapps itself. PS:  I did do t with '' first as I am aware of that requirement but it failed as well

 

I have done a workaround so not a biggie to me at the moment.  but is wierd

 

Work around was to have no filter in  the Get Items.  then do a for each and find the record based on a condition to that action.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (12,117)