cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sasidhar_mudra
Level: Powered On

Issue in Email Body Formatting

Hi All,

 

I created an app and when click, it sends an email. I am not sure where am i going wrong though the function looks OK. 
I want to include "Hi Employee Name" in the body, however, when mail arrives, i see & symbol instead of my text input.
Below are the screenshots, can you please advise where is the error?

 

Everything looks okay except the "Hi" & TextInput7_2, "& is writing only &

 

Email1.jpg

Email2.jpg

 

Please help....

 

Thanks

Sasi

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Issue in Email Body Formatting

Hi @sasidhar_mudra ,

Could you please share a bit more about your scenario?

Do you want to send an Outlook email from your app?

 

Based on the formula you provided, I think there is something wrong with the Office365Outlok.SendEmail(...) formula in your app. The standard Office365Outlok.SendEmail(...) formula as below:

 

Office365Outlook.SendEmail(To, Subject, Body, {From: Text, Cc: Text, Attachments: Table, Importance: Text, IsHtml: Boolean})

 

 

According to the screenshot that you mentioned, I found that you have put the  "Hi" & TextInput7_2 formula within the second argument (Subject part) of the Office365Outlok.SendEmail(...) function rather than within the third argument part (Body part) of the Office365Outlok.SendEmail(...) function.

On your side, please consider modify your formula as below:

 

If(
   IsBlank(TextInput7.Text),
   Set(V1, true),
   Set(V1, false);Office365Outlook.SendEmail(
                                              TextInput7.Text,
                                              "xxxx Meeting for: " & Dropdown5.Selected.Result,  /* <-- This is Subject part. The next is Email body part */
                                              "Hi " & TextInput7_2.Text & " & </br>Please Find  
the below: " & " </br></br>
<b>xxxx</b> " & "</br>
<br>"
& DataCardValue75.Text & "</br> ....,    /* <-- This is Email body part */
                                            {IsHtml: true, Importance: "High"}
                                          )
)

 

 

Please consider take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Issue in Email Body Formatting

Hi @sasidhar_mudra ,

Could you please share a bit more about your scenario?

Do you want to send an Outlook email from your app?

 

Based on the formula you provided, I think there is something wrong with the Office365Outlok.SendEmail(...) formula in your app. The standard Office365Outlok.SendEmail(...) formula as below:

 

Office365Outlook.SendEmail(To, Subject, Body, {From: Text, Cc: Text, Attachments: Table, Importance: Text, IsHtml: Boolean})

 

 

According to the screenshot that you mentioned, I found that you have put the  "Hi" & TextInput7_2 formula within the second argument (Subject part) of the Office365Outlok.SendEmail(...) function rather than within the third argument part (Body part) of the Office365Outlok.SendEmail(...) function.

On your side, please consider modify your formula as below:

 

If(
   IsBlank(TextInput7.Text),
   Set(V1, true),
   Set(V1, false);Office365Outlook.SendEmail(
                                              TextInput7.Text,
                                              "xxxx Meeting for: " & Dropdown5.Selected.Result,  /* <-- This is Subject part. The next is Email body part */
                                              "Hi " & TextInput7_2.Text & " & </br>Please Find  
the below: " & " </br></br>
<b>xxxx</b> " & "</br>
<br>"
& DataCardValue75.Text & "</br> ....,    /* <-- This is Email body part */
                                            {IsHtml: true, Importance: "High"}
                                          )
)

 

 

Please consider take a try with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
sasidhar_mudra
Level: Powered On

Re: Issue in Email Body Formatting

Thanks @v-xida-msft . 

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,692)