cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Issue since last update - An entry is required or has an invalid value

I am finishing up an app created in PowerApps. It's been humming along fine, saving new records, saving edits, etc, until this past Friday where it seems there was another PowerApps update.

 

Now, whenever a new record is saved I get the error 'An entry is required or has an invalid value. Please correct and try again.'

 

The thing is, if I hit save again the record saves just fine. This appears to only be an issue with forms. I've created a new screen, with a new form and still get the same error. In places where I use Patch to create a new record there are no issues. I am using SQL Azure tables as my datasources.

 

I've also tried the CreateDate field mentioned in another post. I already had the field in all of my tables so I've tried removing it and adding it back and the error is the same both ways.

 

Any help or guidance would be greatly appreciated as this app was almost complete until the latest update messed it up.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Issue since last update - An entry is required or has an invalid value

Smiley Happy

Solved! 

 

1. Make the desired read-only, but required Fields (e.g. Title) editable, then hide using the visible property. 

2. Add a label control with the Text property referencing the field you hid.  

View solution in original post

32 REPLIES 32
Super User
Super User

Re: Issue since last update - An entry is required or has an invalid value

I've had the same issue. I did a work around by putting the same SubmitForm(Form1) command I the OnFaiilure selection. Works but still shows the error message temporarily.
Highlighted
Anonymous
Not applicable

Re: Issue since last update - An entry is required or has an invalid value

Hey

 

Have the same issue submitting to Sharepoint! I'm fighting with it for the last few days... I actually thought it was something with one of the data cards in my form - yesterday made a binary search with deleting cards, today just was just deleting data cards by 5 to see if anything changes. In both cases results were strange - in the latter case I narrowed the search to 2 fields (so I basically deleted all data cards besides 2) and these 2 fields on submission were giving me the error (1st - submission error, second - ok). Then, without changing anything, I've decided to submit these 2 fields from the beginning and, suddenly, everything went just fine during the first submit. I made undo and returned 7 more fields in total back to the form - and they got submitted just fine for the first time.  This is very confusing... 😞

 

Best,

 

Nick

Highlighted
Super User
Super User

Re: Issue since last update - An entry is required or has an invalid value

I think I encountered the same or similar issue.

 

I added a field of datatype TimeStamp to my SQL Azure DB tables and refreshed those Datasourses in PowerApps. I deleted the forms in PowerApps and recreated them, including the TimeStamp fields as hidden Datacards.

 

It has been working for me since, though I have seen some other bugs that I've mentioned on the forum (clicking on an item in a gallery selects the wrong record on a form set to gallery.selected; and lookup formulas that won't accept DataCard values unless you perform a numeric calculation on them like multiplying by 1).

Highlighted
Advocate III
Advocate III

Re: Issue since last update - An entry is required or has an invalid value

"I added a field of datatype TimeStamp to my SQL Azure DB tables"

So this solved your initial problem ?

 

I was about to post this as a suggestion, which solved a similar but different problem in another post.

DatabaseMX ('mx')
Microsoft Access MVP
Highlighted
Resolver I
Resolver I

Re: Issue since last update - An entry is required or has an invalid value

I also have this problem with all my forms, haven't found a workaround yet...

 

Edit: Deleting my forms en doing undo changes seems to repair the problem for all my forms.

Highlighted
Advocate I
Advocate I

Re: Issue since last update - An entry is required or has an invalid value

I've found that removing the Record ID (key field) from all the forms resolves the issue in my case. The Record ID fields have been on the forms since I started and worked fine until the last update. But removing them from the form entirely has resolved the issue in my case. 

 

Removing most of the fields and adding them back resulted in the same error message for me. As did deleting the form and re-creating. 

 

Good luck to all having the same issue, I hope you find your resolution (since it seems to be a different fix for everyone.)

 

 

Highlighted
Anonymous
Not applicable

Re: Issue since last update - An entry is required or has an invalid value

would like to check this method but cannot do it cause I get an error when I try to delete the form. Web gives the error and Studio just shuts down without any notification. 

 

EDIT: managed to delete&undo the form - solved the problem partly: no error during the same edit session, however, it reappeares when a new edit session is started. Another negative moment of this method that the order of datacards defined by formula after undo is reset back to integers 1, 2, 3...

 

EDIT2: the error is still present in the published version... removing ID data card (or making it View) from all forms does not help as well... 

 

All this just starts being not fun at all 😞

Highlighted
Advocate I
Advocate I

Re: Issue since last update - An entry is required or has an invalid value

Having the same issue with a form connected to a SharePoint Online list. My app is huge.. really don't want to have to recreate it... Anyone have any update on this?

 

Amy Jo

Highlighted
Frequent Visitor

Re: Issue since last update - An entry is required or has an invalid value

I have the same issue. Is there any sollution?

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (9,660)