cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Power Participant
Power Participant

Issue with Datatable - Author/Editor became [object Object]

I'm currently having an issue with something that was previously working but stopped working as of last week.  In my PowerApp I have a DataTable that is using a SharePoint list as the data source.  That list has a couple of Lookup fields that I'm surfacing in the data table.  This previously worked just fine but now the lookup field values are displaying "object object" instead of the value.  I'm on Version 2.0.783.  is anyone else experiencing this behavior?

10 REPLIES 10
Highlighted
Microsoft
Microsoft

Have you tried with different sharepoint list? or even a CDS datasource with lookup column?

Highlighted
Power Apps
Power Apps

Hi April, I tried some scenarios to try and repro this at our end but not able to. Are you seeing this issue with all lookup fields? Have you tried a different control mapped to the same column to see what it shows? Thanks.

Highlighted

What is the column type for the lookup column in your list ?

Highlighted
Power Participant
Power Participant

Update:  I was finally able to get it working again by removing, re-adding and re-configuring the data table.  I had an issue the week prior where it had wiped my data table so I think this might have been a lingering bug from that.  

Highlighted

That's great!
let us know if you faced this issue again.

Highlighted

April glad to hear that you are not blocked anymore. If you are able to get the older version of the app that has the problem please send it our way so we can investigate and see if this was preventable. You might need to temporarily provide access to the SP list as well (if that is possible). Thanks.

Highlighted

I am having the same issue. I have tried refreshing the data source, removing the data source, and removing the table. None of them have worked. I've had the issue before and dont remember what I did to fix it.

Highlighted

What kind of Data source are you using to connect Data table to?

Are you using the new Data table (preview) control? if so what is the formula in text property of the column with problem looks like?

Highlighted

The data source is sharepoint. I am using a data table, but I don't know if it's new. I've been using it since December. The text property one of the columns I'm seeing the issue in is: ReviewMethod. 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (6,699)