cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BluRonnie
Advocate I
Advocate I

Issue with gallery control getting Orders list from Dynamics

I am building this app to retrieve the project type orders from Dynamics and let the users add new lines and etc. It was working OK in PowerApp release 3.19064.11 and for some reason, it stopped working in both 3.19064.13 and the current version 3.19071.14.

The symptom is: The gallery retrieves no records from Dynamics, but if I remove the data source (Dynamics 365 > Orders) and added it again, it will retrieve the information correctly, but when I try to refresh or save/close/open the app again, the issue comes back. Initially, I thought it may be related to the formula, variable and etc. but the same problem happens even when I just add a new gallery and link it to Orders without any customisation.

However, if I start a new App and add the Orders as a gallery, everything works. 

 

I'm not sure why this happens and if this is related to the new release of PowerApps or maybe Dynamics (as we did notice an issue with Dynamics not displaying project line form properly)

Screenshot - 12_07_2019 , 12_16_09.png

1 ACCEPTED SOLUTION

Accepted Solutions

I have done some changes which seem resolved the issue:

 

  • The gallery was using a collection as part of Items and I have changed it to Orders. SortByColumns(Search(Orders,txtProjectContractSearch.Text,"name"),"name",Ascending)
  • There is a global variable for saving the record of the order selected/created which it is needed for other screens. hence there is a Set clause on the gallery OnSelect to save the selected record from the gallery and also another Set clause on the OnSelect of a "Save" button on the Order Detail screen to save the new record created. I think it could be the 2nd set clause was not done properly which causing the system confused about the definition. 

Once I have done above two changes, the gallery behaves correctly. 

View solution in original post

3 REPLIES 3
v-yuxima-msft
Community Support
Community Support

Hi @BluRonnie 

 

Could you please consider turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-load your app, check if the issue still exists?

Could you please change browsers to test?

 

Best Regards.

Yumia

Thanks @v-yuxima-msft  for the reply.

 

I have just tried to turn off the settings and used the different browser (ie, I was using Chrome) but they didn't help. 

I have done some changes which seem resolved the issue:

 

  • The gallery was using a collection as part of Items and I have changed it to Orders. SortByColumns(Search(Orders,txtProjectContractSearch.Text,"name"),"name",Ascending)
  • There is a global variable for saving the record of the order selected/created which it is needed for other screens. hence there is a Set clause on the gallery OnSelect to save the selected record from the gallery and also another Set clause on the OnSelect of a "Save" button on the Order Detail screen to save the new record created. I think it could be the 2nd set clause was not done properly which causing the system confused about the definition. 

Once I have done above two changes, the gallery behaves correctly. 

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (78,426)