cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AlexKeil
Level: Powered On

Issues with Form.UnSaved

Not sure if this is a bug or expected behavior, i have a form with a bunch of text boxes, lookups, dates etc all going back to an SQL database.

If i setup the form with dates, dropdowns (with the correct allowed values and defaults) the Form.Unsaved works correctly, make a change to a drop-down, updates = true, change back , updates = false. THe issue comes in with Text boxes. The fields in the database default to ('') and then are are varchar(5000). PowerApps will always report that the form has changes when it loads even if the field is blank. I found that if you add TrimEnds() to the default value of the data card (for example TrimEnds(ThisItem.Issue1) where issue1 is a field) then it works correctly. Anyone else come across something like this or am i missing something in the database setup?

 

Thanks!

6 REPLIES 6
Community Support Team
Community Support Team

Re: Issues with Form.UnSaved

Hi @AlexKeil,

The Unsaved property of the Edit form control determines if the Edit form control contains user changes that have not been saved. If the EditForm1.Unsaved formula return true, it means that your Edit form contains some changes have not be saved.

I have made a test on my side, and don't have the issue that you mentioned. The GIF screenshot as below:Test1.gif

In addition, I found that if I set the Default property of the Data card control which contains the Text Input control to following:

""   /* <-- Empty string */

the EditForm1.Unsaved formula would always return TRUE when I load the Edit form in New mode.

Note: The "" (empty string) is not equal to blank. The "" (empty string) is a Text string value, just there is no character within this string.

Please check if you have set the Default value of the Issue1 field in your SQL table to "" (empty string). If yes, please consider take a try to remove the Default value for the Issue1 field in your SQL table, then check if the issue is solved.

If you have set a "" (empty string) as a default value for the Issue1 field in your SQL table, when you load your Edit form in New mode, the corresponding Text Input box in your Edit form would be set with a Default value ("", empty string), so the EditForm1.Unsaved formula would always return TRUE  on your side.

If the issue still exists, please consider re-create your SQL table without setting a Default value for the Issue1 field, then create a new app to connect it, check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
DE1
Level: Powered On

Re: Issues with Form.UnSaved

Wasn't sure whether to bump this or start a new thread. But as of today the Unsaved property is returning True when I haven't made any changes to the form. Can you fix this please?

CindyZ
Level: Powered On

Re: Issues with Form.UnSaved

I am having the same issue.  I am navigating from a button to a New form.  My Form Display Mode label shows: edit.  My Unsaved changes messages visibility is set to newForm.Unsaved.   As soon as I get to my new form, the message is already visible without touching a key stroke.  

 

Also, I do not see a delay output option on a label on which I have text but I've seen in in older videos.  Is that no longer an option?  

 

Thanks!

JNicholl
Level: Powered On

Re: Issues with Form.UnSaved

Did either of you ever find a solution to this problem / is it still an issue for you both? I'm experiencing something similar, but unsure if its due to the same thing.

CindyZ
Level: Powered On

Re: Issues with Form.UnSaved

@JNicholl  I have not but I've also not worked in that app recently.  I will be back into later this week and in some weeks ahead so if I do find a solution, I'll post it here.  

BartSchaap
Level 8

Re: Issues with Form.UnSaved

I have the same issue. I use the following statement in the default property of text input control in order to format it:

Text(Value(Parent.Default), "[$-nl-NL] ######0,00" )

This causes the [formname].Unsaved property to become true.

THIS IS A MAJOR BUG please MSFT fix this !!!!!!

Without a fix it is not feasible to do any proper formatting in a form.

 

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Kudoed Authors (Last 30 Days)
Users online (3,706)