cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Carmiol
Regular Visitor

Items showing up on Edit View, but NOT showing up mobile app (published app)

Hello,

 

I'm having a problem that I just can't seem to fix.

 

I have an app connected to a sharepoint list.

 

I have a BrowseGallery that pulls some items from the list.

 

Now here is the tricky part.: In the Edit View, everything works perfectly.  I hit the "play" button and everytihng does what it's supposed to.  However I Save and Publish, open the mobile app, and the BrowseGallery is blank.

 

I already tried doing another "connection to Sharepoint" from the mobile app, still not working.  Also tried "deleting" the entire connection from Edit View, and establishing it again, also not working.

 

Please help!

1 ACCEPTED SOLUTION

Accepted Solutions
Carmiol
Regular Visitor

Re: Items showing up on Edit View, but NOT showing up mobile app (published app)

OK, trying a little more I just answered my own question.

 

One of the columns was a "calculated" date and another one of the columns was a regular date.  The calculated date is interpreted as a text by Powerapps.

 

So for example the date was 8/10/17

 

There was a filter that checked if both dates were the same and only showed the items that had the same date in both columns.

 

Filter was:

 

DateValue( CalculatedDate ) = RegularDate

So in the computer this added up nicely, and the BrowseGallery would show the applicable items.

 

In the phone however, because the regional settings were different, it would somehow interpret the date wrong.

 

So regular date of 8/10/17 was 10 August 2017

but Calculated Date of 8/10/17 was 8 October 2017

 

Don't know why it does one correctly and the other one incorrectly.  Probably has to do with the fact that CalculatedDate is a text for Powerapps.

 

Anyways, solved it by adding "en-US" to DateValue:

 

DateValue( CalculatedDate, "en-US" ) = RegularDate

View solution in original post

1 REPLY 1
Carmiol
Regular Visitor

Re: Items showing up on Edit View, but NOT showing up mobile app (published app)

OK, trying a little more I just answered my own question.

 

One of the columns was a "calculated" date and another one of the columns was a regular date.  The calculated date is interpreted as a text by Powerapps.

 

So for example the date was 8/10/17

 

There was a filter that checked if both dates were the same and only showed the items that had the same date in both columns.

 

Filter was:

 

DateValue( CalculatedDate ) = RegularDate

So in the computer this added up nicely, and the BrowseGallery would show the applicable items.

 

In the phone however, because the regional settings were different, it would somehow interpret the date wrong.

 

So regular date of 8/10/17 was 10 August 2017

but Calculated Date of 8/10/17 was 8 October 2017

 

Don't know why it does one correctly and the other one incorrectly.  Probably has to do with the fact that CalculatedDate is a text for Powerapps.

 

Anyways, solved it by adding "en-US" to DateValue:

 

DateValue( CalculatedDate, "en-US" ) = RegularDate

View solution in original post

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (6,282)