cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper II
Helper II

Lag in Screen Transition

Hi All,

 

I am building a PowerApps with SharePoint as my data source. The problem that i face is when ever i navigate from one screen to another it just lags a bit and when the screen moves to another screen previous buttons and all show up in the next screen. like a basic lag that you see in screen transition.
Can anyone help me resolve this.

i currently have 60 items in my gallery. 
when i navigate from one screen to another there is a lag which the users will not like. 

7 REPLIES 7
Super User III
Super User III

A number of things can cause that. 

Do you have formulas Onvisible of your screen and what are they if any.

Also what do you have on the items property of the Gallery?

 

Since your record is only 60, loading should be quite fast.

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

@eka24 the problem is not only the time taken to move to a new screen  but when I move from one screen to another, the buttons image overlap to the next screen. So that gives a bad user experience.

Can you show a screenshot

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Community Support
Community Support

Hi @Jayant2 ,

 

Have your issue been fixed? If not, could you please share more details on your app?

Did you set any Transition Argument for navigate() function? Reference: Navigate 

If that's not what I'm talking about, please show us your App the since there are many factors that may cause to slow down the performance.

How many controls in screen? Did you put lots of formulas in Screen.OnVisible or Screen.OnHidden property? These preview features are also probably the reason for the issue, please change them to see if the issue can be fixed?

Snipaste_2020-10-20_09-58-53.png

 

 

Sik

 

@v-siky-msft the issue still exists.

The transition argument is just Transition type which is fade. 
Navigate(Screen name, Fade)
My Home screen contains in total
one background image
3 buttons with 3 html control to give them a shadow.

 

There is no code on on visible or on hidden of screen, it is on appstart so I don't think so it should face such an issue in transition.

I tried turning off the preview features but it did not work.

Please find the image for reference, first attachment is Home page , when I click on any of the buttons this issue exists in attachment 2 as issue.

Hi @Jayant2 ,

 

Does this issue happen in all browsers? I never met such kind of issue.

I would suggest you submit a Support Ticket to Microsoft for further assistance.

 

Sik

@v-siky-msft i tried submitting an issue ticket but it does not submit the ticket but provides me alternative solutions. 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,543)