cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TimWatts
Frequent Visitor

Launch function issue

Hi Everyone, 

 

I am running a power app inside of a Power bi report that is accessible within a Team group in MS teams. 

The issue I am having is that I want to be able to use the launch function to open an external URL. 

using the app in a browser works fine but inside teams it doesn't know what to do and a pop-up comes up saying. 

"You will need a new app to open this about link" then has an option to search the Microsoft store. 

My guess is that is due to an app running inside teams rather than Power bi having any issue with it. The reason I dont think its Power Bi related is that I can open an external URl without issue from within Power Bi. 

 

Any thoughts?

 

 

 

2 REPLIES 2
Aapok
Resolver II
Resolver II

My first instinct is that you are not specifying a protocol in your link, so PA can't interpret which application to launch the link in. I had something similar, where my Launch would function would work just fine when used in a browser, but wouldn't work when using the app on mobile (through the PowerApps application).


Check if your links start with "https://...". If this is the case already, then it's most likely something with how PA works inside teams, which I have no experience of.

Thank you for the idea, tried a few different versions and couldnt make it work. 😞

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (1,842)