cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jrines
Level: Powered On

Launch("tel:" & fieldname) question

I am calling to a SharePoint List that has all of my vender telephone numbers.

 

I have a field call Office Phone.

 

I want to create a button that will call the number in the field from my iphone

 

I update the button property in the OnSelect field with Launch("tel:" & Office_x0020_Phone) and it does not work

 

Any thoughts or suggestions?

 

Thanks

 

26 REPLIES 26
Power Apps Staff Chris
Power Apps Staff

Re: Launch("tel:" & fieldname) question

I just tried this on my iPhone 5 with a simple button with OnSelect action Launch("tel:555-555-5555") and it opened the caller.  Could you check the values you are getting from the sharepoint list (i.e. value of the Office_x0020_Phone field)?

jrines
Level: Powered On

Re: Launch("tel:" & fieldname) question

I can't get it to run at all.

 

On the Button in the OnSelect parameter my entry is: Launch("tel:"&Office_x0020_Number)

 

I have a Yellow Triangle that say Invalid Name.

 

If I make the OnSelect command: Launch("tel:4431234567") it works fine.

 

Please advise

hpkeong
Level 10

Re: Launch("tel:" & fieldname) question

Hi  @jrines

 

Launch("tel:"&FieldTitle.Text).

Please chec that it is from a fieldtitle.Text

 

TQ

 

hpkeong
jrines
Level: Powered On

Re: Launch("tel:" & fieldname) question

Hello hpkeong

 

I am new at this so please don't laugh.

 

I change my button OnSelect to Launch("tel:"&Office_x0020_Number.Text) and I still get Invalid Name.

 

Is this correct?

 

FYI:  The Office Number field is a text field from a SharePoint list.  The telephone number is entered as 123-456-7890

 

Thaks for replying.

 

Please advise.

 

 

hpkeong
Level 10

Re: Launch("tel:" & fieldname) question

Hi @jrines

 

I am learning, too! Just sharing my little knowledge. No worry.

I guess it might the Tel Phone No format affects.

Normally, when you key in tel no, you will not have

- 444-555-666, where "-" is not recognized.

Can you please try to amedn your data base to remove "-"?

 

Let me know it really works.

Sorry to say that I am only using Excel and CDS but not SPL.

hpkeong
jrines
Level: Powered On

Re: Launch("tel:" & fieldname) question

I can't get this command to work at all.  If anybody has any suggestion please reply.

 

Recap:

 

I have a Share Point List with vendor names and telephone numbers.  There is a field named Phone that has the vendor telephone number.  I want to be able to lookup the vendor and call from my iPhone.

 

I created an app.  I can lookup the vendor. 

 

I added a Button and on the OnSelect I added the following command:  Launch("tel:" & Phone)

 

When I run the app and hit the Button nothing happens.

 

If I change the OnSelect command to Launch("tel: 4431234567") where I hard code the telephone number it works.

 

Does anyone have any suggestions?

 

Thank you.

HenryMabuti
Level: Powered On

Re: Launch("tel:" & fieldname) question

Hi Guys,

 

Can someone tell me why the Launch("tel:" & phonenumber) suddenly stopped working on mobile phone device?

 

I have implemented this command on my powerapps app with phone details from our AD and it was working since it was initially deployed long time ago until now.

 

When the Launch("tel:" & phonenumber) is executed, an empty browser is displayed and nothing happen.  The Launch("sms:" & mobile phone number) also stopped working.

 

Regards,

 

 

Henry

Power Apps Staff Chris
Power Apps Staff

Re: Launch("tel:" & fieldname) question

Hi Henry,

 

What device and OS version is it failing on for you?  Could you please share the session ID of a session in which you tried this and failed?

 

Thanks!

Chris

HenryMabuti
Level: Powered On

Re: Launch("tel:" & fieldname) question

Hi Chris,

 

I am using Samsung A5 with OS version 6.0.1.

 

My session details: Session ID: d4dd4d14-511f-6b16-e798-7769c972ad47

 

I have re-downloaded Powerapps from Google App Store. As well as logged off and logged on my Powerapps company account but to no avail.  

 

Note though that the Launch("tel:"&mobile) appears to work on IPhone.

 

Your usual reply would be greatly appreciated.

 

Kind Regards,

 

 

Henry

 

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Kudoed Authors (Last 30 Days)
Users online (3,722)