cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

LookupField in powerapps not showing value in Editform mode but works in new form mode.

ArunKrishnan_0-1605654848160.png

Hi All,

My lookupfield 'itemDensityFC' is behaving strange.

It looks up data based on two combo box selections in database in SP(Item Level).

In New form Mode = when i select top 2 dropdowns it displays corresponding density value in lookupfield at bottom.

in Editform Mode = it has no data in display and hence ruins the depending calculations. But still on save it doesnt affect SP list.

 

So basically its just showing up on screen but having the data stored in background i think. Any thoughts?

 

4 REPLIES 4
Microsoft
Microsoft

Hi @ArunKrishnan ,

 

Do you want to make the TextInput box auto populated with the value corresponding to that two combo box selections?

 

If you do, you need to apply that formula in Text property instead of Default.

 

About Text and Default properties, please refer to this doc:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/controls/control-text-input#key-propert...

Default  – The initial value of a control before it is changed by the user.

Text  – Text that appears on a control or that the user types into a control.

 

Hope this helps.

 

Best regards,

Community Support Team _ Jeffer Ni
If this post helps, then please consider Accept it as the solution to help the other members find it.

Hey @v-jefferni 

 

Thanks for looking into this.

1. I cant find text property for the 'ItemDensityFC' text box.

2. also observed that in the Editmode, initially there is no data visible. But when i reselect the top 'itemname' combobox it comes back with value.

 

Any thoughts please?

Hi @v-jefferni 

I can see why ItemDensityFC field is not showing value.

1. It is dependent on two combo boxes on top as u saw in picture.(Project ID and Item ID).

2. The 'item ID' when selected and saved, still doesnt reflect data in SP list. Refer pic below. For some reason its not sending data back to SP list when an item is selected here. 

if that saves data back to SP list then things will be fine i guess. thats why everytime i select again in Editmode it works but later goes away.

ArunKrishnan_0-1605701757809.png

 

Hi @ArunKrishnan ,

 

Could you please share more details about the "ItemID" list? What Data source does the Form link to? What is the Form's Item prpperty holding?  

 

You mentioned that 'itemDensityFC' is LookUp field, is it a custom card in that form? I'm confused of your scenario so if possible please share enough details about those lists and the form, such as list columns with their types and Form's data source, Item, Update of ItemID and itemDensityFC Data Cards.

 

Best regards,

Community Support Team _ Jeffer Ni

 

 

Helpful resources

Announcements
secondImage

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

Top Kudoed Authors
Users online (63,573)