cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jonathanO
Level: Powered On

Microsoft Flows Stored Procedure

I created a flow that executes a stored procedure.  The flow is attached to a button in powerapps.  I created the powerapp, flow, and on premise sql connections.  When I press the button that the flow is attached to, the stored procedure executes successfully.

I have shared the app, flow, and SQL connection with a team member and when they press the same button, they get the following error:

 

The service returned an error: RemoveHold: stpUpdateVehicleHold (TEST)!Run: 1 error(s) occurred. Reporting the first one: Error

 

I saw this article , however, I have already added my team member as an owner of the flow.  I have also deleted the flow and re-created it.  Any other ideas of how to solve this issue?

8 REPLIES 8
Microsoft mayuro
Microsoft

Re: Microsoft Flows Stored Procedure

Do you have a session id for when it does not work? You can get the session details from Account -> session details

jonathanO
Level: Powered On

Re: Microsoft Flows Stored Procedure

Hello Mayuro,

 

The session ID when this error occurred was 90c026c6-e01d-f5a3-a697-96faa86c1359.

 

However, another one of my teammates created a copy of the flow and it worked for everyone.  The copy was exactly the same.  I still do not know why the flow I created caused that error.

brendanmorley86
Level: Powered On

Re: Microsoft Flows Stored Procedure

All of my Flows are Team Flows and the connection is embedded within the app but none of the users can use any of them. Session ID: 54499ce2-8345-4ee1-8239-3b9b5ecbbfd1
PowerApps 2.0.750

Microsoft mayuro
Microsoft

Re: Microsoft Flows Stored Procedure

I do see the errror in the logs - and am looking more. There might be a simple work around - can you try to remove the flows - save and then re add them - save - i think that should resolve the issue..

 

Also what all connectors (other than Translator) do your flows use?

Microsoft mayuro
Microsoft

Re: Microsoft Flows Stored Procedure

the issue looks like a new connection was added to the app or Flow but the local connection reference store was not updated because we used our cache. you may have modified your flow and will need to be re-import it. I would restart studio, open the app for editing, remove the flow and readd it.

brendanmorley86
Level: Powered On

Re: Microsoft Flows Stored Procedure

I am now getting a different error. It now says, "connection not configured for this flow".

 

Session ID: c7b07429-7c6e-48f3-af41-850fcfea59d7
PowerApps 2.0.750

Power Apps Staff erga
Power Apps Staff

Re: Microsoft Flows Stored Procedure

@brendanmorley86 Which connections is your Flow using? I see that you are trying to use Microsoft Translator -- are you trying to use any other connector (i.e. Google Drive, OneDrive)? If it is easier, we can communicate via email (erga@microsoft). 

WPB
Level 8

Re: Microsoft Flows Stored Procedure

@erga

 

Having the same problem... tried to change names, recreate from a new flow... Nothing works.

I find weird that the source is from the west while I'm in Montreal...

Capture.PNG

 

Capture1.PNG

 

 

If you need any other info, don't hesitate!

RequestId: d50087d7-3a1e-4e5f-9bb6-5620065bdf92

 

Thanks for your help!

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (8,932)