cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lnico11
Frequent Visitor

Microsoft Forms Organizational form not loading

Hello, 

I've added multiple forms to a built power app to collect responses. It seems as though only the forms which are set to. "Anyone with the link can respond". Once I select "Only people in my organization can respond", the form no longer loads. 

I need to record who responded so this is important to the app. Has anyone run into this issue and had any luck solving it? 

Thanks!

6 REPLIES 6
poweractivate
Super User II
Super User II

@lnico11 

Try:

 

  1. Clear Cookies and Cache, and retry
  2. Remove and re-add the data source from PowerApps, then retry #1, then retry it.
    1. Also, after doing this, try clicking the refresh icon a few times in PowerApps Maker as well.
  3. Remove the Microsoft Forms connection, and then if needed recreate the Connection by removing the connection under make.powerapps.com -> Data -> Connections -> Find Microsoft Forms Connection -> Use Ellipses ->  Remove Microsoft Forms Connection., then retry #2, then retry #1, then retry it.

 

It works on my laptop at the create.powerapps website. However it does not work on any tablets. So clear the cookies and cache on each tablet, or my computer? 

* Just tried clearing Cache on the powerapps app on my Ipad, did not resolve the issue. 

 


I've tried removing and adding the connection twice, no luck. 

@lnico11 

 

On each tablet as well.

 

Also, on each tablet and as each user, the connection should be removed and readded as well in case it resolves it.

 

@lnico11 

 

We were not able to add Forms Pro connector to one of our currently available testing tenants, so we couldn't double check, but also you can try this (if applicable):

 

  1. make.powerapps.com -> Data -> Connections (from the App Author this time)
  2. Find Microsoft Forms Pro
  3. Press Ellipses
  4. Look for "Share" option
  5. If the "Share" option is there, try to share connection to all relevant users of the app.
    1. If it is not there, then this is not a potential solution. Even if it is there, this may still not be the final solution.

Share is not there. I cannot seem to resolve the issue. The moment I take the form out of organization only it works, but that defeats the purpose of my created powerapp.

Just another odd observation: The form loads when opened anywhere on a computer. It only gets stuck on the mobile devices. 

lnico11
Frequent Visitor

Continuing to do what I can to troubleshoot:

If I switch the setting of the form anyone can access it loads. After it loaded I switched it back, and submitted a form successfully. It logged my username as it should, but will not reload upon refresh. 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (48,384)