cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
klogsdon
Level: Powered On

Missing Connections when Exporting my App...Resource list is empty

I have created a App. I wanted to export and import to another instance so i could change the connection setup as documented.... (Need to pick what SQL DB it will use)

well I go to my list of apps... click the 3 dot button... select Export package

The Export Dialog comes up and the Related resources list is EMPTY... i should have SQL connector listed

i tried exporting and importing anyway and after the import completes, i have a very empty app with nothing but a single blank screen......... i have multiple test apps in my environment and the others list the same identical SQL connector and work

any advice appreciated... this is a large app and i really dont want to have to recreate.... FYI... the App runs fine in the Studio... i have never added and then removed any connectors....just added what i use in the app, so nothing should be orphaned

1 ACCEPTED SOLUTION

Accepted Solutions
klogsdon
Level: Powered On

Re: Missing Connections when Exporting my App...Resource list is empty

I have found a solution to the problem.... but the problem for the original file still exists... 

 

I found a good post on how to correct orphaned connector references on line and decided to pull the app locally to a MSAPP file

 

I renamed to zip, used 7 zip to look at all of the files and as i had thought, there were no orphaned references. but i did learn a bit more about how the app file is constructed

 

I ended up loading the saved local MSAPP file back into powerapps under a new name.... idecided this would be a good candidate to try just about anything, so i started an export and BOOM... my connectors are there.... the file exported and imported as expected

So saving the file out locally, bringing it back in undr a new name aligned the stars and my problem is gone.....

View solution in original post

1 REPLY 1
klogsdon
Level: Powered On

Re: Missing Connections when Exporting my App...Resource list is empty

I have found a solution to the problem.... but the problem for the original file still exists... 

 

I found a good post on how to correct orphaned connector references on line and decided to pull the app locally to a MSAPP file

 

I renamed to zip, used 7 zip to look at all of the files and as i had thought, there were no orphaned references. but i did learn a bit more about how the app file is constructed

 

I ended up loading the saved local MSAPP file back into powerapps under a new name.... idecided this would be a good candidate to try just about anything, so i started an export and BOOM... my connectors are there.... the file exported and imported as expected

So saving the file out locally, bringing it back in undr a new name aligned the stars and my problem is gone.....

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Users online (5,101)