cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Super User
Super User

Morning after updates? Variable Issues

I was up late working on an app. Around 11:30PM things started slowing waaaayy down. I imagine PowerApps was pushing some kind of update in the background. I stopped working because it was just too laggy (I needed to go to bed anyway!). 

 

Lately I've been playing with "Pseudo-CSS per https://davidlozzi.com/2018/02/21/custom-style-sheets-for-powerapps-pseudo-css/".

This morning ALL variables that refer to another variable in my "pseudo-CSS" file say "Invalid use of " . " " I was using this set of variables all day yesterday with now issue. 

 

Please investigate if this was indeed the result of an update. 

 

Thanks

 

2018-05-17_7-50-40.png

8 REPLIES 8
Highlighted
Super User
Super User

Interestingly enough...

 

As I was about to go into this file and start deleting all the internally-referenced variables... I deleted the first reference and the red squigglys went away FOR ALL internally-referenced variables. When I pasted it back in, all squigglys remained clear. 

 

Seems like I had to just delete and paste back to get the formula working again... weird.

Highlighted


@ericonline wrote:

Interestingly enough...

 

As I was about to go into this file and start deleting all the internally-referenced variables... I deleted the first reference and the red squigglys went away FOR ALL internally-referenced variables. When I pasted it back in, all squigglys remained clear. 

 

Seems like I had to just delete and paste back to get the formula working again... weird.


 

Do you have this in your OnVisible property?

 

If so on first view in the editor it's possible it's not getting a value for your varLayout.HeaderHeight etc. defined to reference.

 

 

Highlighted

Hi @JRaasumaa

 

Right now its set to OnSelect of a button because I continually update styling as things are built. For some reason it just wasn't getting past the first reference. 

 

On a side note, was there an update pushed last night?

Highlighted


@ericonline wrote:

Hi @JRaasumaa

 

Right now its set to OnSelect of a button because I continually update styling as things are built. For some reason it just wasn't getting past the first reference. 

 

On a side note, was there an update pushed last night?


 

The SET command does not work well as an OnSelect, can you put this all into your OnVisible?

 

If you close and re-open your app you will probably get the red underlines again as the OnSelect will not fire creating a variable to use for those properties referencing within each set. The OnVisible will fire off as the screen is shown and allow those variables within the set to see each other.

 

No updates last night, this is all about where you are creating your Set assignments from.

Highlighted

Thanks for the response. I've been using this method (OnSelect to Set) for over a week now. The plan is to move it to OnStart once I get the app closer to production. In the whole last week, I had no issues opening app and clicking "Apply Styles" to get started. Really feels like something that just happened. 

 

No biggie 🙂

 

On a side note, do you know if there are performance concerns when setting a bunch of styling elements using variables? My friend told me to watch out for it. 


@ericonline wrote:

Thanks for the response. I've been using this method (OnSelect to Set) for over a week now. The plan is to move it to OnStart once I get the app closer to production. In the whole last week, I had no issues opening app and clicking "Apply Styles" to get started. Really feels like something that just happened. 

 

No biggie 🙂

 

On a side note, do you know if there are performance concerns when setting a bunch of styling elements using variables? My friend told me to watch out for it. 


 

No performance issues that I've seen with many elements all looking to either set values or even using their own internal lookups for answers. We have a few screens that change their entire layout and look/style based on where the user came from initially and it works great.

Highlighted

Hm. Ok. In my example I have ~160-200 form labels looking directly at varLabel.size, varLabel.color, etc.

 

Wondering if there is any performance concerns with this approach versus having all form labels look at one label (form_label1.size, .color, etc.) and just controlling this ONE label with a variable. 

Highlighted


@ericonline wrote:

Hm. Ok. In my example I have ~160-200 form labels looking directly at varLabel.size, varLabel.color, etc.

 

Wondering if there is any performance concerns with this approach versus having all form labels look at one label (form_label1.size, .color, etc.) and just controlling this ONE label with a variable. 


 

If you can try it with that many labels and report back on performance that would go a long way to helping others with similar situations. Hopefully it all functions fine!

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (10,057)