cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Multiline text field and strange output

Hi everyone,

 

I have a multiline text input field in a PowerApps form, connected to a list in SPO. It is also set up as multiline in SPO.

 

When someone is creating a new list item, the multiline text input field is properly blank, but after input has been made and the item saved, it generates "<div class="ExternalClass4412B4F498D14C7A8CA00337A6075684">Hello there!</div>".

 

For example, if I were to create an item and input "Hello there!" in the multiline text input field, the result would show as:

image.png

 

It basically adds in the whole "<div class=" etc etc formatting in there. This is just a regular, multiline plain text input field. Any ideas why this is happening? I've tried looking to see if any formatting is applied, but it's really just a straight up text field.

 

Thanks in advance, everyone!

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Jeff_Thorpe
Super User
Super User

Normally when I see this it is because the multi line text column in SharePoint is set to use enhanced rich text. If the column does have this setting and you are only using it for text then you can turn it off.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

3 REPLIES 3
Jeff_Thorpe
Super User
Super User

Normally when I see this it is because the multi line text column in SharePoint is set to use enhanced rich text. If the column does have this setting and you are only using it for text then you can turn it off.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

Anonymous
Not applicable

That was it. 🙂 After disabling rich text, it fixed it.

 

Even if rich text is enabled, why would the whole formatting div=class thing appear, if only regular text is inputted? 

 

Thanks so much!

@Jeff_Thorpe   When you change the format to plain text, will you lose all the previous data in different format?

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (14,940)