cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Yama_Vin
Level: Powered On

Mutli selection combobox not showing value from sharepoint List

Hi Community,

We have created a from in PowerApps which saves the data in to a SharePoint list.  All the field values are getting saved in the SharePoint list after submitting the form but, when we open the form, the combo box values are not displaying . When we checked in the SharePoint list we see values are saved.

Can anyone please tell us why we are not able see values in the combo box?  Its a multi selection combo box  and its getting value from a choice column in SharePoint list .

Please let me know if you need any other details .

 

Appreciate any help on this.

 

Thanks,

YAMA_Vin

 

1 REPLY 1
Community Support Team
Community Support Team

Re: Mutli selection combobox not showing value from sharepoint List

Hi @Yama_Vin ,

Could you please share a bit more about the formula you typed within the Items property of the ComboBox?

Do you enable "Allow multiple selections" option for the Choice column in your SP List?

Do you custom a form in your SP list or create a standalone canvas app?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please consider set the DefaultSelectedItems property of the ComboBox to following:

ThisItem.ChoiceField

 

If you custom a form in your SP list using PowerApps, please consider edit your custom form app, then set the DefaultSelectedItems property of the ComboBox to following:

LookUp('SPList', ID = SharePointIntegration.SelectedListItemID).ChoiceField

set the OnNew property of the "SharePointIntegration" control to following:

Refresh('SPList');
NewForm(SharePointForm1)

set the OnEdit property of the "SharePointIntegration" control to following:

Refresh('SPList');
EditForm(SharePointForm1)

set the OnView property of the "SharePointIntegration" control to following:

Refresh('SPList');
ViewForm(SharePointForm1)

then re-publish your app to SP list, then try the custom form app again, check if the issue is fixed.

 

If the issue still exists, please consider re-generate a new app or re-customize a new form in your SP List, then try your app again, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
thirdimage

Power Platform 24

Check it out!

thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (5,772)