cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
anabananei
Resolver I
Resolver I

Navigate Onselect is not working

Hi,

 

We are having issues with the navigate function. All is well until now, whenever users click a button, it does not do what its supposed to do, which is navigating to the second screen. I have a button OnSelect: Navigate(TLScreen_1, ScreenTransition.Fade), it works on preview mode but when I publish, it does not work to users. Tried substituting with Navigate([@TLScreen_1], ScreenTransition.Fade), works on 1 item, then won't work on the rest.

 

I am using SharePoint Customized Form and we haven't had a problem before. By the way, the buttons are not inside a data card.

 

Hope I can someone help me with this.


Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @anabananei & @get-spoash ,

Do you mean that the navigate action will not be triggered in sharepoint custom form sometimes?

I've made a similar test and met the same problem.

After I publish the sharepoint custom form, the navigate action will be triggered at the beginning. see my attachment 58.gif

But if I refresh the website for multiple times, the navigate action will not be triggered. see my attachment 581.gif.

 

I have reported this bug to our product team.

If there's any reply, I will leave message here.

Anyway, thanks for your feedback!

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6

Hello @amitchandak , 

 

I tried the solutions but to no avail. I just confirmed that it varies from user to user. I have 2 buttons, each has function to navigate to separate screen. As we have tested:

 

Me: Button 1 to Screen 1 working

       Button 2 to Screen 2 not working

 

User 1: Button 1 to Screen 1 working

            Button 2 to Screen 2 not working

 

User 2: Button 1 to Screen 1 not working

            Button 2 to Screen 2 working

 

Then After I refresh my page without republishing, both buttons are not working. When I tried to edit and republish, all buttons are working but when I refreshed again, I'm back to the scenarios above.

 

Is there something wrong with powerapps now? 

 

Note: I'm not editing the app until we encountered the issue.

 

Thanks!

We are experiencing the same issue across multiple tenants. We have tested quite a few different scenarios but basically when we edit the powerapp and complete the form we can use the form as  per usual, then we try again and the navigate does not work.

 

We tried changing the Onselect to a set property and a submit and they both worked.

 

We also found that in different forms, sometimes we could get to screen 3 or 4 then the navigate on the next screen would not work and then other forms we could not get past the first screen. 

Hi @anabananei & @get-spoash ,

Do you mean that the navigate action will not be triggered in sharepoint custom form sometimes?

I've made a similar test and met the same problem.

After I publish the sharepoint custom form, the navigate action will be triggered at the beginning. see my attachment 58.gif

But if I refresh the website for multiple times, the navigate action will not be triggered. see my attachment 581.gif.

 

I have reported this bug to our product team.

If there's any reply, I will leave message here.

Anyway, thanks for your feedback!

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hello @v-yutliu-msft ,

 

This seems to be resolved now. Thank you.

Hi @anabananei ,

I'm so glad that you've solve your problem.

Could you mark my answer as your solution?
Thanks!

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

Top Solution Authors
Top Kudoed Authors
Users online (98,572)