cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
TGrounds
Level 8

Nested Gallery - Trying to reference selected data from SubGallery to filter additional screens

Background:

 

I have 2 gallery controls (I have consolidated two screens into one by nesting the controls)

 

  • There is a Vertical Gallery listing 'Applications' - from a datasource called 'Apps'
  • Nested within the 'Applications' gallery is a Horizontal Gallery listing 'Functions' - from a datasource called 'Functions' filtered on the App Code from the 'Applications' Gallery Control

These are displaying as expected.  Within the Sub-Gallery I have two Icons which navigate to subsequent screens (Features, & Specifications) which use two additional data sources that I filter from values from 'Functions'.  However, now that these controls are nested, when I try to display the title on the both of these screens from a text box in the Sub-Gallery (Functions) called 'Function_Title',  and when I try to filter the data on both screens from a text box in the Sub-Gallery (Functions) called 'Function_Code' both cases now have these values as blank.   

 

When these now combined Galleries were split into two different screens I was able to simply set the title on the new screens simply referencing the text boxs directly.  

 

Is there something I need to do differently to access the selected sub-gallery information?  All of the sub-gallery fields are avaialble in the intellisense leading me to believe that they are avaialble in this context - so I'm curious to know why the values are not?

 

Thanks -

Tom. 

2 ACCEPTED SOLUTIONS

Accepted Solutions
TGrounds
Level 8

Re: Nested Gallery - Trying to reference selected data from SubGallery to filter additional screens

I thought I found the answer - When I fully qualified the object I was able to get the selected values (NestedGalleryName.Selected.DescriptionTextBox.Text).  I updated my PowerApp and tested all of the referenced and then saved and published it.  Now when I run the PowerApp it is NOT working, and when I go into the development environment and run it there - same results.  It's no longer working.  This appears to be a bug of some kind.  Has anyone else experienced this?

View solution in original post

TGrounds
Level 8

Re: Nested Gallery - Trying to reference selected data from SubGallery to filter additional screens

This does appear to be a bug.  I added two text boxes to the primary gallery (Applications) caled 'SelectedFunctionTitle' and 'SelectedFunctionCode' - and set them to the fully qualified item FunctionListing.Selected.FunctionTitle.Text and FunctionListing.Selected.FunctionCode.Text and the two text boxes populated.  Then I went to make the change for my subsequent forms to use these new text boxes - and when I navigated to the form they were working with the fully qualified value.  I saved and published and they are working as expected.  So it appears that the primary gallery had to have a label to hold the selected value of the sub-gallery and when that was in place then the fully qualified reference appears to work.

 

To clean up the app, I adjusted all subsequent screens to use the new text boxes.

View solution in original post

2 REPLIES 2
TGrounds
Level 8

Re: Nested Gallery - Trying to reference selected data from SubGallery to filter additional screens

I thought I found the answer - When I fully qualified the object I was able to get the selected values (NestedGalleryName.Selected.DescriptionTextBox.Text).  I updated my PowerApp and tested all of the referenced and then saved and published it.  Now when I run the PowerApp it is NOT working, and when I go into the development environment and run it there - same results.  It's no longer working.  This appears to be a bug of some kind.  Has anyone else experienced this?

View solution in original post

TGrounds
Level 8

Re: Nested Gallery - Trying to reference selected data from SubGallery to filter additional screens

This does appear to be a bug.  I added two text boxes to the primary gallery (Applications) caled 'SelectedFunctionTitle' and 'SelectedFunctionCode' - and set them to the fully qualified item FunctionListing.Selected.FunctionTitle.Text and FunctionListing.Selected.FunctionCode.Text and the two text boxes populated.  Then I went to make the change for my subsequent forms to use these new text boxes - and when I navigated to the form they were working with the fully qualified value.  I saved and published and they are working as expected.  So it appears that the primary gallery had to have a label to hold the selected value of the sub-gallery and when that was in place then the fully qualified reference appears to work.

 

To clean up the app, I adjusted all subsequent screens to use the new text boxes.

View solution in original post

Helpful resources

Announcements
Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Join THE global Microsoft Power Platform event series

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Microsoft Business Applications Virtual Launch

Join us for the Microsoft Business Applications Virtual Launch Event on Thursday, April 2, 2020, at 8:00 AM PST.

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (8,624)