cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

New Records

I seem to be having issues with adding a new record (I am using an Azure DB if that makes any difference)

 

The form only seems to let me submit a new record once, maybe twice. After that it doesnt work. I have to delete the form and re-make it. Its not a data validation issue, as I have tested it on using the same data (which sometimes also works twice)

 

Sometimes the form doesnt even reset to new when I open my add record screen even though i use:

 

NewForm(Form1);Navigate(Add_Invoice,ScreenTransition.Fade)

 

The Button in the Add_Invoice screen simply is:

 

SubmitForm(Form1)

 

The form itself, other than DataSource simply has an OnSuccess function of:

 

Back()

 

The OnSuccess function does work, and only goes back when it does submit.

 

The Cards functions are as follows: (using my database field CompanyName as the example)

 

DataField
"CompanyName"

 

Default

ThisItem.CompanyName

 

DisplayName

"CompanyName"

 

Update

Value1.text   (I have also tried:          Value(Value1.text)

 

 

 

 

The functions of the text input inside of the card are as follows:

 

Action:

OnChange

False

 

OnSelect

False

 

Data

 

Default

Parent.Default

 

 

 

Its driving me crazy. Please could someone help me identify where I am going wrong??

3 REPLIES 3
Highlighted
Resolver II
Resolver II

Re: New Records

As you mentioned, I am not quite sure what your actual problem is because your work on PowerApps looks right to me

Have you checked if the problem is on your DB's side.

- Did you check the constraints that you apply on the target table(s)?

- Did you try the same test record directly to DB?

Highlighted
Advocate I
Advocate I

Re: New Records

Yes I did.

 

It seems to be somthing to new with the New command, becaise it doesnt always seem to work?

Highlighted
Microsoft
Microsoft

Re: New Records

Hi VinnyClegg,

I have tested in my environment, it can work always. It will not stop working after submitting the form once or twice.

 

And my PowerApps version number is 2.0.430, you could compare your PowerApps version number with mine. And you could update the PowerApps to the latest version to check if it can work.

 

Best regards,

 

Sara Fan

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,030)