cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WC-KSTILL
Helper III
Helper III

New & Edit Button not working in Modern View

Hey everyone,

A lot of our SharePoint lists have stopped working suddenly. The New and Edit buttons basically do nothing when clicked.

 

What they have in common is they are a power app form. Oddly, the buttons work without issue if I manually type the URL in the browser or switch to classic mode.

 

It's also not all power app forms, only the ones that have a sql connection, when I check the SQL connection they do show as connected though. I am stumped and even Microsoft can't figure it out. Has anybody seen this before?

29 REPLIES 29
AlecMaly
Frequent Visitor

We are also having a similar issue. Doesn't affect all forms on all lists, nor does it affect new lists with newly created PowerApp forms. 

I have a minor workaround I've been using. I created two columns and hid them from forms so the users don't see them when adding a new or editing an item. Just need to add them to each view and move them to the beginnging.


The new columns I named them New and View/Edit

 

New Button:

{
  "$schema": "https://developer.microsoft.com/json-schemas/sp/column-formatting.schema.json",
  "elmType": "div",
  "children": [
    {
      "elmType": "a",
      "style": {
        "font-size": "21px",
        "margin": "2px"
      },
      "attributes": {
        "href": "NewForm.aspx"
      },
      "children": [
        {
          "elmType": "button",
          "txtContent": "New Item",
          "style": {
            "font-family": "Segoe UI,-apple-system,BlinkMacSystemFont,Roboto,Helvetica Neue,sans-serif",
            "font-size": "12px",
            "cursor": "pointer",
            "background-color": "#8cbf26",
            "border": "none",
            "color": "white",
            "padding": "5px 5px",
            "text-align": "center",
            "text-decoration": "none",
            "display": "inline-block"
          }
        }
      ]
    }
  ]
}

View Button:

{
  "$schema": "https://developer.microsoft.com/json-schemas/sp/column-formatting.schema.json",
  "elmType": "div",
  "children": [
    {
      "elmType": "a",
      "style": {
        "font-size": "21px",
        "margin": "2px"
      },
      "attributes": {
        "href": "='DispForm.aspx?ID=' + [$ID]"
      },
      "children": [
        {
          "elmType": "button",
          "txtContent": "View/Edit Item",
          "style": {
            "font-family": "Segoe UI,-apple-system,BlinkMacSystemFont,Roboto,Helvetica Neue,sans-serif",
            "font-size": "12px",
            "cursor": "pointer",
            "background-color": "#8cbf26",
            "border": "none",
            "color": "white",
            "padding": "5px 5px",
            "text-align": "center",
            "text-decoration": "none",
            "display": "inline-block"
          }
        }
      ]
    }
  ]
}

These work fine for now, until MS & PA get their crap together.

 

This is what it looks like:

Buttons.png

@jb007@WC-KSTILL@AlecMaly@edgar3tres ,

 

Any update on the your issue? I have opened a ticket for a custom list form where we are seeing a smilar issue. Our issue is till under investigation and the last update from the PowerApps support team was that they were collaborating with the SharePoint team because they think the issue could be on the SharePoint side.

 



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.
Anonymous
Not applicable

I am seeing this issue as well.  We're on  SPO with a contact list using the Modern layout.  The +NEW and EDIT buttons quit working on my custom PA forms last Friday (29-SEP-19). I am able to edit all of the information using QuickEdit mode, but it is less than desirable in the long run. When I click on the PowerApps menu I get this as well.

 

PA-forms-issue.png

 

So I have to go through List Settings and use the Forms link to actually edit inside PowerApps. Can a Microsoft representative give us an update on what's happening and when it might be resolved?

 

Thanks,

gpence

@Jeff_Thorpe 

No update here, still broken.
I have a call scheduled with Microsoft support at 2pm EST; I don't forsee any resolution, but the more people reporting the issue the better.

Same issue here.  New/+ Button in Modern view does not do anything. It should be opening up my integrated PowerApp form. If I switch to Classic View, it works, which is strange, because the instructions in the List form settings state that the "new" experience is required for PowerApps.

No updates here.


We are still using the workaround I posted for now.

 

I think we might ditch PowerApps and start looking into a new solution.

Is there another step here?  You said you created two new columns, then you showed code for two buttons.  How are the buttons linked to the columns? Are you creating the buttons by editng the page and inserting the code in a web part? or using JSON to format the two new columns?

@Runner55552 

 

I create two new columns - Single line of Text

 

Add the JSON code at the very bottom. Save


List Settings >Advanced settings > Allow management of content types? > YES

 

List Settings > Content Types > Click your content type, Issue, Item, etc


Click New Columns you created > Column Settings > Hidden (Will not appear in forms)


Then I edit the views and move these to the very front. 1 and 2.

 

 

 

 

Just tried this and it worked!  Thanks so much.  I have no idea why a customized New Item button like this works vs. the out of the box New/+ button, but it does!  Nothing like a little coding to solve things and workaround Microsoft issues.....

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (70,813)