cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Njh_560
New Member

New records not appearing

I am very new to PowerApps and programming. I have built a canvas app from a list of records in excel. I realised after I had built the app that there were limitations to using excel so transferred the record to a SharePoint list and deleted the excel file. I switched over the data source to the SharePoint list and the app is working well. I have increased the amount of records to look up to 2000 which easily covers the amount of records in my database (1500).

 

The difficulty I am now facing is that when I create a new record within the app, it adds it to the SharePoint list. However, the record does not appear within the gallery view/search in other parts of the app.

 

I have used the refresh function on the data source and used refresh as part of the formulas within the app and still the records do not appear.

 

Looking at the SharePoint list the only difference between the new records and the old records I imported from excel is that there is a _powerappsid_ column with a code which the new records do not have. Is this the cause of the problem? Any ideas? 

1 ACCEPTED SOLUTION

Accepted Solutions
eka24
Super User III
Super User III

Use this:

Filter( ClientList, StartsWith( FirstName, TextInput3.Text ) || StartsWith(Surname, TextInput3.Text ) )

 

If you still have issues, give the Data type of those columns. 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

5 REPLIES 5
eka24
Super User III
Super User III

From your description I get that then New record you saved is not appearing in the SharePoint list and therefore also not appearing in the App?

 

If that is the case please what formula are you using to save you record in Power App?

Also have you checked your right or permission to save to SharePoint?

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

The record does appear on the SharePoint list but does not appear within the gallery in another part of the app when I want the user to search the records to pull up someone’s details. 

I use the following formula when saving the record....

OnSelect = SubmitForm(Form1);Navigate(HomeScreen,fade);Refresh(‘Clientlist’) 

eka24
Super User III
Super User III

If it appears in the SharePoint then rather show the formula on the items of that Gallery. 

 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

Njh_560
New Member

When I click on the gallery the formula is...

 

items=Search(‘Clientlist’,TextInput3.Text, “Surname”, “FirstName”)

 

There is a TextInput above the gallery as a search box. 

eka24
Super User III
Super User III

Use this:

Filter( ClientList, StartsWith( FirstName, TextInput3.Text ) || StartsWith(Surname, TextInput3.Text ) )

 

If you still have issues, give the Data type of those columns. 

------------

If you like this post, give a Thumbs up. Where it solved your request, Mark it as a Solution to enable other users find it.

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (27,584)