cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Kingpin
Kudo Kingpin

Newly added SharePoint fields dont show up in PowerApps dev environment when you refresh datasource

Im editing a powerapp and then I add a new field to the sharepoint list that the form Im editing uses as its datasource. I hit refresh, slose the app and reopen, etc. and it doesnt show up.

this is a brand new field that was not rename or changed.

This is killing me right now. Any ideas?

Brian Kennemer
Projectified Consulting
www.projectified.com
brian.kennemer@projectified.com
4 REPLIES 4
Highlighted
Kudo Kingpin
Kudo Kingpin

The workaround is to add a new form to the same screen and then delete that new form. THEN the new field shows up in the existing form. Grrr. 

Brian Kennemer
Projectified Consulting
www.projectified.com
brian.kennemer@projectified.com
Highlighted

BrianKennemer - Thanks for your post. I tried your method and believe it worked for me. However, I had to go back into the data connection and refresh.

Highlighted

yeah sometimes I get it to work without the refresh and sometimes I have to refresh. It is not consistant for me.

Brian Kennemer
Projectified Consulting
www.projectified.com
brian.kennemer@projectified.com
Highlighted

I agree! Let's hope it starts to be consistent! Smiley Very Happy

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,678)