cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

No Item to Display but only when I run the App

Hi

If you check out the top screenshot with my App open in the Desktop, the data populates the Edit Form.

However in the screenshot below that, when I run the app I see "No Item to Display".

It's got me stumped. You assistance will be greatly appreciated.

Regards, Mark.


P1.png

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

thanks Mark anyway,

I tried something and the following helped me:
1. on the Editform in the Editscreen there is a Property "Item"
2. this property needs to be set also to, for example "BrowseGallery1.selected"
3. this BrowseGallery can be found the browse screen

View solution in original post

10 REPLIES 10
Highlighted
Community Support
Community Support

Hi Skemaz,

 

Where did you run this app? On a tablet? If so, make sure that you are using the tablet layout when you create the app. Also I saw in the screenshot that all the data cards and text box are too wide to fit in with the app display screen. 

0.PNG

 

Please adjust this and then have a try.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted


Mona,

 

I am having the same issue, however, I am using the phone layout on a laptop. I can not get my form to display when I select preview. 


 

Highlighted

Hi

Thanks for your assistance.

I'm running on a Windows10 2 in 1 machine and the App is in Tablet Mode.

When I created the app for Tablet mode, it set the app to a defaukt size of 4:3 (iPad).

Later I tred to switch it to 16:10 (Widescreen).

When I made the change 3 things happened:

(1) My font sizes were increased and I had to manually fix them because they were way to big.

(2) The issue you pointed out in your screenshot where the Gallery stayed the same size meaning it didn't stretch to match the new resolution. I cannot fix this at the moment because the setting available for sizing the Gallery control doesn't allow this.

(3) When I go back to the "Screen Size and Orientation" setting I see it's been set back to 4:3 (iPad)! - see screenshot below.

It's a bit of a mess but I'm trying to work through the issues one at a time starting with why I see the "No Item" message rather than the Edit fields.

If anything comes to mind to assist I'll be most grateful.

Thanks, Mark.

p2.png

 

 

Highlighted

Hi Mark, did you manage to solve the "no item to display" issue? I have the same issue and I can't figure out why this happens...

 

willem

Highlighted

Or any one else suggestion?

Frequent Visitor

Hi Willem
I wound up trashing what I had built and used a template.
Sorry I can't be more helpful.
Regards, Mark.
Highlighted

thanks Mark anyway,

I tried something and the following helped me:
1. on the Editform in the Editscreen there is a Property "Item"
2. this property needs to be set also to, for example "BrowseGallery1.selected"
3. this BrowseGallery can be found the browse screen

View solution in original post

Highlighted

Thanks it works Smiley Very Happy

Highlighted
Frequent Visitor

Many thanks for the update.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (13,116)