cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
pinya
Frequent Visitor

No data source provided - Sometimes error/Sometimes works

Hi there,

 

i cannot find any solution to my problem.

Three weeks ago, i have created Sharepoint custom form on my list in SHP site. Everythink works fine, until this week.

When i run Edit/View/New i get "No data source provided". Nothing on screen is evaluated, for example, when "Colour" is set to formula If(...",RGBA(),RGBA()), it is return as Black (0,0,0,0).

The same on "Y" property, when is set as  to formula, returns everywhere 0.

Everythink on form is not evaluated. Logo is also not showing....

 

It looks like, Attachment1.

------------------------------------

This Customized form has 2 Screens. When i thy to skip on second screen on Edit/View/New i get the same - Not evaluated first page...

 

I am reallly confused, bcs i tried recreate the Form,

then try to create this customized form on another list (1:1), but still the same error on another list.

I found this post:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/No-Data-Source-Provided/m-p/348286#... 

I have allready set all forms to FormMode.Edit.

 

-------------------------------------

 

In PowerApps studio is everythink OK, when i publish app, it works sometimes 3 times/2 times. Then it is stop working.

I have 3 testing Users. The same behavior on this 3 accounts.

 

But suprisingly on IE this Customized form is working...??? in others browsers not.

I have tried clear Cache on another browsers but still the same.

Sometimes, when i open form after long time (2 hours), again it works 3 times/2 times and then again stop working (Not data source provided).

 

On this site i have 5 anothers customized forms and all of them works fine.

 

What is intresting for me, Data source from Main form is set to "[@dtbReklamace]". I dont understand why it stars with @, but it was set automatically with Sharepoint integration.

Another Customized form have datasource set without with @ on start and they works fine...

 

Can you help me please...

Thank you so much

 

 
 
 
 

 

3 REPLIES 3
v-siky-msft
Community Support
Community Support

Hi @pinya ,

 

When did you found this issue? Can you share the Items property of Form?

I have made test on my side, also have the similar issue. The form works well before I modify it. But after I edit and publish it, It will always show the specify record, It seem that "SharePointIntegration.Selected" doesn't work. For further test, I change the Items property of Form to "SharePointIntegration.Selected", when I want to View/Edit the record, the form will always show "Getting Data" ,which further verifies my conjecture: something wrong happened to 'SharePointIntegration' connection.

 

Form's Items :SharePointIntegration.SelectedForm's Items :SharePointIntegration.SelectedForm's Items: If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First([@'Test 0910']),SharePointIntegration.Selected)Form's Items: If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected),First([@'Test 0910']),SharePointIntegration.Selected)

I will submit this issue to PowerApps Teams, and I will post back if there is any update.

Best regards,

Sik

If my post is helpful for you, please click on “Accept as Solution” to help other members find it more quickly.

Thank you for reply @v-siky-msft 

 

This issue i found before 10 days on first form, it was after 2 weeks from the creation.

 

But I think you have another issue, bcs. my error is "No data source provided" and yours is "Getting your data".

 

Sometimes when my Customize form load propertly, (for example todays morning it works for 2 times), selected items from Sharepoint list is loaded propertly.

My "Item" looks like yours:

If(IsBlank(SharePointIntegration.Selected) || IsEmpty(SharePointIntegration.Selected);First([@dtbReklamace]);SharePointIntegration.Selected)

But yes, if is something wrong with Sharepoint integration, that could be mu problem too.

 

So when you found some update from Teams, post it here please

Thank you 🙂

 

 

How i said,

 

in PowerApps studio everythink works fine.

When i publish and then run Form from Sharepoint List sometines it works but most often not.

 

But in PowerApps studio i got twice this error:

 

WebAuthoring abnormal termination.

Client date/time: 2019-11-09T22:08:34.146Z

Version: 3.19104.33 (v3.19104.33.130671691)

Session ID: 6e7216ee-a183-439a-b584-8502f45d04c6

description: {"exception":{"message":"XMLHttpRequest error(string). <!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 4.01//EN\"\"http://www.w3.org/TR/html4/strict.dtd\">\r\n<HTML><HEAD><TITLE>Bad Request</TITLE>\r\n<META HTTP-EQUIV=\"Content-Type\" Content=\"text/html; charset=us-ascii\"></HEAD>\r\n<BODY><h2>Bad Request</h2>\r\n<hr><p>HTTP Error 400. The request is badly formed.</p>\r\n</BODY></HTML>\r\n","name":"UnhandledError","_isCritical":true,"detail":{"exception":{}}},"error":"[circular]","promise":{"_oncancel":null,"_nextState":null,"_state":{"name":"error","enter":"[function]","cancel":"[function]","done":null,"then":null,"_completed":"[function]","_error":"[function]","_notify":"[function]","_progress":"[function]","_setCompleteValue":"[function]","_setErrorValue":"[function]"},"_listeners":null,"_value":"[circular]","_isException":false,"_errorId":34,"done":"[function]","then":"[function]"},"id":34,"setPromise":"[function]"}

stack: t@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/Core.js?v=3.19104.33.130671691:...

t@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/Core.js?v=3.19104.33.130671691:...

o.prototype._translateError@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/AppMagic.WebAuthoring.js?v=3.19...

o.prototype._raiseTerminalError@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/AppMagic.WebAuthoring.js?v=3.19...

o.prototype._unhandledException@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/AppMagic.WebAuthoring.js?v=3.19...

o.prototype.executeAsync/</<@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/AppMagic.WebAuthoring.js?v=3.19...

u/</<@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/Core.js?v=3.19104.33.130671691:...

u/<@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/Core.js?v=3.19104.33.130671691:...

u@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/js/Core.js?v=3.19104.33.130671691:...

q@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/openSource/modified/winjs/js/base....

enter@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/openSource/modified/winjs/js/base....

_run@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/openSource/modified/winjs/js/base....

_chainedError@https://cdn-paaprodweu.azureedge.net/v3.19104.33.130671691/studio/openSource/modified/winjs/js/base....

 

.....

 

And about 17 pages in word...

 

Can someone explain that, please?

Thanks in advance.

 

 

 

 

 

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,699)