cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

No emails from users requesting access to app

Until recently, when a user requests access to the app i'm the owner of, I'd get an email with their request. Now, I'm not getting their emails. They're sending me screenshots of their 'request sent' screens, and I've tested this with a co-worker by un-sharing it and having them request access, only for the email to never arrive.

Has something changed regarding owner notifications? Can I restore the original notification method?

5 REPLIES 5
Community Support
Community Support

Hi @epiej ,

Do you not share your app to your end users, instead, share the App Url to them and ask them to request access?

 

I have made a test on my side, and don't have the issue that you mentioned. The Request Access Notification email sent well as below:

2.JPG

 

Please check if your are the owner/creator of the canvas app your end users send Request Access to. Also please check if you have shared your app to the request user already from your PowerApps Portal.

 

If you have shared your canvas app to the request user already, you would not get the request access notification email from the request user. If the end user could not access your app with the App Link of your app, please check if they have signed in with proper credential to access the App Link.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

There are some users who are getting the URL without the app being shared with them first. We expected they would be met with the 'you don't have access, please request access from owner', screen, they send the request (again, they sent me screenshots of their 'request sent' screens.

 

I am the owner of the app, and the people who are requesting access are new people, not shared with before. There are people sharing the link to the app within my organization, and I'm supposed to green-light them when their request comes in.

Anonymous
Not applicable

I am also experiencing this issue.

When a user clicks on the "request access" link on the "This app isn't opening correctly" screen, I am no longer receiving email notification of the requests, although this was something I received previously.

Helper V
Helper V

For troubleshooting this issue -- email notification not coming through, I need to verify the things below with you: 1. Have you configure outgoing email for the web application where the access request has been set? Please check if you have typed the SMTP server name in the Outbound SMTP server box and the email address in the Form address box. 2. Please check if the email address which you have typed to configure outgoing email and the email address set in access request settings is validated. 3. Go to site settings > User and Permissions > Access requests and invitations, could you view the requests?

I've actually started receiving people's request emails again. Not sure what's changed.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,917)