cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

No items to display - Tabview

Hello Team,

 

I am working on a PowerApps form that's set in the Tablet view mode. There are no errors on this form as far as I know. However, when I click on the Preview button on the top right hand side, I get a blank screen with a message that says "No items to display".

I could publish the form over to the SharePoint site.

 

Thanks,

Shashanka

1 ACCEPTED SOLUTION

Accepted Solutions
JRaasumaa
Level 10

Re: No items to display - Tabview


@Anonymous wrote:

@JRaasumaa Thanks for responding.

 

This PowerApps form was created from a SharePoint form. So, this by default has a datasource.

 

Thanks,

Shashanka


 

Does that data source have a record though? Being connected to data and being connected to data with an actual stored line of information are two different things. If there isn't a record to display you will probably get empty or blank screens.

 

Can you add a test row to your data to see if that resolves your issue?

View solution in original post

5 REPLIES 5
JRaasumaa
Level 10

Re: No items to display - Tabview


@Anonymous wrote:

Hello Team,

 

I am working on a PowerApps form that's set in the Tablet view mode. There are no errors on this form as far as I know. However, when I click on the Preview button on the top right hand side, I get a blank screen with a message that says "No items to display".

I could publish the form over to the SharePoint site.

 

Thanks,

Shashanka


 

If your form is not connected to a data source it will not display any fields. Are you positive you are connected to a data source with at least 1 record available for it to display?

Anonymous
Not applicable

Re: No items to display - Tabview

@JRaasumaa Thanks for responding.

 

This PowerApps form was created from a SharePoint form. So, this by default has a datasource.

 

Thanks,

Shashanka

JRaasumaa
Level 10

Re: No items to display - Tabview


@Anonymous wrote:

@JRaasumaa Thanks for responding.

 

This PowerApps form was created from a SharePoint form. So, this by default has a datasource.

 

Thanks,

Shashanka


 

Does that data source have a record though? Being connected to data and being connected to data with an actual stored line of information are two different things. If there isn't a record to display you will probably get empty or blank screens.

 

Can you add a test row to your data to see if that resolves your issue?

View solution in original post

Community Support Team
Community Support Team

Re: No items to display - Tabview

Hi @Anonymous,

 

Please check on the DataSource and Items property of the Form. Make sure that you have put your SharePoint List Name in DataSource property. 

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: No items to display - Tabview

Thanks for responding, Mona!

 

This helped. There were a few hiccups even after changing the field properties on the list. But, once the app was re-started it seemed to work fine.

 

Thanks again,

Shashanka

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (4,983)