cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MihirY
Advocate IV
Advocate IV

Not able to add custom API in PowerApps as Custom Connector

Issue: Custom connector in PowerApps by calling Azure API management

Platform: Office 365
I have a sample webapp where I have deployed my test WebAPI into it. when I test normally by accessing URL with /api/values which is working fine. Now I want to add this as connector to my PowerApp to access web API. I have done following things to achieve this

  1. Created API Management for this web app.
  2. Created new API. I have tested this and showing results as desired.
  3. I went to PowerApps and trying to create a custom connector using "Create from Azure service (preview)" option. 
  4. I have selected my subscription details and my api management name but when I select my custom API it is giving below error. But when I select default api which is echo-api then there is no issue. What would be the resolution for thisMihirY_0-1596563146090.png

     

0 REPLIES 0

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,348)