cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate III
Advocate III

Not able to copy sharepoint ID using Flow

1.3.jpg1.4.jpg

 

I have used a flow to copy sharepoint ID to RECid field but I am unable to do it.... dunno why..??? 

Also, When the flow runs, SDM/BSC Value -1 field gets automatically updated by Operating Profit.... Can anyone help!!

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Not able to copy sharepoint ID using Flow

Hi @bhrigu12,

 

1) You could see that Id field is marked as a required field in the "Update item" action. This is because that Flow would use this field to identify which item to be updated. It will update the item whose ID matches the ID you put in this action. IDs of each items are created by SharePoint automantically when you first create each item and cannot be changed later.  

 

2) Is your SDM/BSC Value -1 column a Lookup column? If not, what's its column type?

 

I have a lookup column that would look like this in the Update Item action, but I can pick the value for this field. So I wonder if you have picked "Operating Profit" option when you create this flow.

Capture.PNG

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate III
Advocate III

Re: Not able to copy sharepoint ID using Flow

Hi Mona,

 

1). Sorry, I think I dint explain the problem correctly. Actually, I need the Sharepoint ID to get concatenate with the Title something like "Title-ID" in another Column. When I tried doing concatenate using formula I dint get the option of ID. So I tried copying ID to another column i.e RECid and than concatenate with Title. The flow was working initially but i did some mess around and its not working now. Can you help copying ID to another column??

 

2). Column type is Choice (Dropdown). Whenever the flow runs, the sharepoint gets updated with the default value (Operating Profit is default value of that column). I have removed the default value and kept it as blank. Hope it will work.

 

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020 Winner Announced

Check it out!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (10,286)