cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Not able to get Employee Org to work

Hi

Im pretty new to Powerapps and love the concept.

 

I tried to start from template Employee Org app and cannot get it to work. Seems like its not able to search our Office 365 users:

 

Command im using : Left(Office365Users.MyProfile().GivenName;1)&Left(Office365Users.MyProfile().Surname;1)

 

When i do a museover on the code it tells me that i need to be logged into the service to get access.

When running the app i can search and no errors, but it dosent give me any details on the search.

 

We have Azure AD with Dir Sync to office 365, not sure if this creates some issues ?

 

Anyway, thanks for support and look forward to a solution.

3 REPLIES 3
Highlighted
Helper I
Helper I

Re: Not able to get Employee Org to work

Hi @Anonymous,

 

Please refer following link for details to bind Office365Users details:

https://powerapps.microsoft.com/en-us/tutorials/connection-office365-users/

Highlighted
Community Support
Community Support

Re: Not able to get Employee Org to work

Hi Tskaaren,

 

I test your code on my side, it is working fine.


I create a connection to Office 365 Users first, then add a Text box control, and set its Text property as:

Left(Office365Users.MyProfile().GivenName,1)&Left(Office365Users.MyProfile().Surname,1)

1.png

 

So please make sure you have created properly connection to Office 365 Users.

 

And I am not sure with this sentence “When running the app i can search and no errors, but it dosent give me any details on the search”, what kind of search are you doing?
Could you give me more details about this?


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Anonymous
Not applicable

Re: Not able to get Employee Org to work

Hi

thanks for feedback, i tried all suggestions and it still gives me error.

 

When opening the app it states i need to be logged into the service to make it work, when checking Office365 data connection it shows as loggin in and OK.

 

As you can see on the picture, code is ok but returns a warning triangle and states that office 365 service is not logged on.

 

PowerApps ORG.png

 

Helpful resources

Announcements
Ignite

Microsoft Ignite

This will be a conference that you do not want to miss!

secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (3,424)