cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Not able to update or create custom connector

Hi,

 

Whenever I try to update an existing custom connector or create a new custom connector it loads for a while and finally shows the following error : 

Client request aborted. Please see 'http://aka.ms/powerAutomateClientRequestAborted' for more details.

Please find the screenshot in the attachment.

 

Let us know if you need any further info.

 

Thank you,

Dheeraj

4 REPLIES 4
Highlighted
Microsoft
Microsoft

Hello,

 

As mentioned in the link, companies may set firewalls or block their users from unknown domains or IP addresses, which can be one of the reason why you get this error.

 

https://support.microsoft.com/en-us/help/4557620/client-request-aborted-or-failed-to-fetch-error-in-...

 

Did you try creating the custom connector through postman collection? 

If it works through postman, then you can export the collection and import it when creating the custom connector.

 

https://docs.microsoft.com/en-us/connectors/custom-connectors/define-postman-collection

 

F12 network trace can also help gather more information around what other errors are logged when you try creating the connector.

 

 

Highlighted
Helper I
Helper I

@pdheeraj ,

 

have you found solution for this?

I am also having this problem on updating my custom connector.

 

Thanks.

Highlighted

Dear @pdheeraj , @rohsh354 ,

 

I hardly believe, but the explanation about firewall blocking IP address, could be relevant.

Basically I managed to update my custom connector by:

  • Connecting to a terminal server 
  • The terminal server is in different location (even different continent), thus having different IP address
  • Login to powerapps from the browser in terminal server, and just update the connector.

 

Hopefully this helps others too. 

Highlighted
Frequent Visitor

I am getting the same issue updating connectors, in multiple different environments and networks. I cannot believe it is a firewall issue, because very occasionally it does work. I found unblocking 3rd party cookies to *.microsoft.com, *.dynamics.com and *.office.com helps a bit, but still getting issues most of the time. 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,731)