cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Oliver89
Frequent Visitor

Office365 photo error in Gallery

Hi All,

 

I'm facing a problem that although i read a bunch of forum posts, i can't solve. the Scenario is the following

 

Connections:

Dataverse (Contacts (standard table))

Office365Users

 

Object:

Gallery

 

Gallery Items: Contacts

Problematic object in gallery : Image

 

The image in the Gallery is defined as follows: (NOTE: nophoto is a dummy image to fill in case of error)

If(Office365Users.UserPhotoMetadata(ThisItem.Email).HasPhoto=true ,Office365Users.UserPhotoV2(ThisItem.Email) ,nophoto)

 

Now the situation is, the gallery properly shows the dummy image in case of erro but, the app in play mode popos up 1000000 of errors on top of the screen saying like:

 

on the home screen (where i even don't have this gallery) : 
Office365Users.UserPhotoV2 failed: The method 'UserPhotoV2' has an invalid value for parameter 'id'


and on the screen where i have the gallery, right when i navigate there and also when i scroll in the Gallery:

(XXXX would be a mail, but you know GDPR :D)


Office365Users.UserPhotoMetadata failed: { "error": { "code": "ErrorInvalidUser", "message": "The requested user 'XXXXXX" is invalid.", "innerError": { "date": "2021-04-21T15:31:50", "request-id": "bf517981-235b-4fb2-9f41-a01752204715", "client-request-id": "bf517981-235b-4fb2-9f41-a01752204715" } } }

 

 

Anyone any workaround?

Thx in advance!!!!!!

Oliver

 

 

 

2 ACCEPTED SOLUTIONS

Accepted Solutions
v-qiaqi-msft
Community Support
Community Support

Hi @Oliver89,

Do you mean that you could successfully display the image but there is an error message popping up in play mode?

Actually, it is an known issue with the Office365Users.UserPhoto() function in PowerApps. Based on the formula that you mentioned, I think you are correct.

Please consider turn on the "Formula-level error management" option within Advanced settings of App settings of your app, then re-published your app, check if the issue is solved.

v-qiaqi-msft_0-1619058101880.png

Check if it helps.

Regards,

Qi

 

View solution in original post

Thanks QI,

 

your suggestion seems to have solved the issue, though i hope i'll not have future issues caused by the fact that the
 "Formula-level error management"  is an experimental feature 😕 MS doesn't recommend to use those on "live apps"

View solution in original post

2 REPLIES 2
v-qiaqi-msft
Community Support
Community Support

Hi @Oliver89,

Do you mean that you could successfully display the image but there is an error message popping up in play mode?

Actually, it is an known issue with the Office365Users.UserPhoto() function in PowerApps. Based on the formula that you mentioned, I think you are correct.

Please consider turn on the "Formula-level error management" option within Advanced settings of App settings of your app, then re-published your app, check if the issue is solved.

v-qiaqi-msft_0-1619058101880.png

Check if it helps.

Regards,

Qi

 

View solution in original post

Thanks QI,

 

your suggestion seems to have solved the issue, though i hope i'll not have future issues caused by the fact that the
 "Formula-level error management"  is an experimental feature 😕 MS doesn't recommend to use those on "live apps"

View solution in original post

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

Top Solution Authors
Top Kudoed Authors
Users online (70,647)