cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WI-User-01
Helper I
Helper I

On Premise Gateway - Hardened Windows Server

I have a SQL database on a Windows server I manage and I installed the On-Premise Gateway software.  When I attempt to login, Microsoft redirects to my company’s authentication, and, since it appears the Gateway software is using IE’s interface, I’m presented with a series of script errors and am not able to login/authenticate. 

 

It recommends turning off compatibility view settings, which I have.  IE on servers is “security hardened”.  I've reverted the IE sercurity to its lowest level and changed all the tweaks I could find that were relevant, however, nothing seems to make it work.  I’ve tried running the gateway software as Administrator (I’m already a local administrator).

 

Anyone experience a similar issue or have a solution?  Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
JRaasumaa
Memorable Member
Memorable Member


@WI-User-01 wrote:

I have a SQL database on a Windows server I manage and I installed the On-Premise Gateway software.  When I attempt to login, Microsoft redirects to my company’s authentication, and, since it appears the Gateway software is using IE’s interface, I’m presented with a series of script errors and am not able to login/authenticate. 

 

It recommends turning off compatibility view settings, which I have.  IE on servers is “security hardened”.  I've reverted the IE sercurity to its lowest level and changed all the tweaks I could find that were relevant, however, nothing seems to make it work.  I’ve tried running the gateway software as Administrator (I’m already a local administrator).

 

Anyone experience a similar issue or have a solution?  Thanks in advance.


 

Is the version of IE on the server updated? Most of the Windows Authentication fails miserably with anything before version 10 on our servers due to similar script issues.

View solution in original post

3 REPLIES 3
JRaasumaa
Memorable Member
Memorable Member


@WI-User-01 wrote:

I have a SQL database on a Windows server I manage and I installed the On-Premise Gateway software.  When I attempt to login, Microsoft redirects to my company’s authentication, and, since it appears the Gateway software is using IE’s interface, I’m presented with a series of script errors and am not able to login/authenticate. 

 

It recommends turning off compatibility view settings, which I have.  IE on servers is “security hardened”.  I've reverted the IE sercurity to its lowest level and changed all the tweaks I could find that were relevant, however, nothing seems to make it work.  I’ve tried running the gateway software as Administrator (I’m already a local administrator).

 

Anyone experience a similar issue or have a solution?  Thanks in advance.


 

Is the version of IE on the server updated? Most of the Windows Authentication fails miserably with anything before version 10 on our servers due to similar script issues.

View solution in original post

Thank you for the suggestion, updating to IE11 resolved the authentication issue.  Much appreciated!  


@WI-User-01 wrote:

Thank you for the suggestion, updating to IE11 resolved the authentication issue.  Much appreciated!  


 

Glad to help!

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

Top Solution Authors
Top Kudoed Authors
Users online (73,547)