cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
gax700
Level: Powered On

On premises Data Gateway Error (Unable to load DLL!!!)

Hi everyone,

just updated OPDG to latest version (3000.6.202) and now all my connected powerapps applications give me this error when trying to access data in SQL Server:

 

An error occurred on the server. Server Response: Not a valid connector response. returning message as is: { "error": { "code": 502, "source": "europe-001.azure-apim.net", "clientRequestId": "ac9dbef5-41be-4763-9109-8159e40c3c8c", "message": "BadGateway", "innerError": { "status": 502, "message": "Unable to load DLL 'Microsoft.PowerBI.DataMovement.Pipeline.XPress9.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

 

Any help appreciated... I'm trying to reinstall previous version in the mean time.

 

Thanks,

Cris

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
gax700
Level: Powered On

Re: On premises Data Gateway Error (Unable to load DLL!!!)

UPDATE: I've reinstalled June update and restarted the server. Now it works.

 


@gax700 wrote:

Hi everyone,

just updated OPDG to latest version (3000.6.202) and now all my connected powerapps applications give me this error when trying to access data in SQL Server:

 

An error occurred on the server. Server Response: Not a valid connector response. returning message as is: { "error": { "code": 502, "source": "europe-001.azure-apim.net", "clientRequestId": "ac9dbef5-41be-4763-9109-8159e40c3c8c", "message": "BadGateway", "innerError": { "status": 502, "message": "Unable to load DLL 'Microsoft.PowerBI.DataMovement.Pipeline.XPress9.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

 

Any help appreciated... I'm trying to reinstall previous version in the mean time.

 

Thanks,

Cris


 

View solution in original post

1 REPLY 1
Highlighted
gax700
Level: Powered On

Re: On premises Data Gateway Error (Unable to load DLL!!!)

UPDATE: I've reinstalled June update and restarted the server. Now it works.

 


@gax700 wrote:

Hi everyone,

just updated OPDG to latest version (3000.6.202) and now all my connected powerapps applications give me this error when trying to access data in SQL Server:

 

An error occurred on the server. Server Response: Not a valid connector response. returning message as is: { "error": { "code": 502, "source": "europe-001.azure-apim.net", "clientRequestId": "ac9dbef5-41be-4763-9109-8159e40c3c8c", "message": "BadGateway", "innerError": { "status": 502, "message": "Unable to load DLL 'Microsoft.PowerBI.DataMovement.Pipeline.XPress9.dll': The specified module could not be found. (Exception from HRESULT: 0x8007007E)

 

Any help appreciated... I'm trying to reinstall previous version in the mean time.

 

Thanks,

Cris


 

View solution in original post

Helpful resources

Announcements
thirdimage

Coming Soon: T-Shirt Design Contest

Keep your eyes open for our upcoming T-shirt design contest!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (5,951)