cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PowerBuilder
Frequent Visitor

OnSuccess Rule (Start Flow) works on all platforms but Phone Apps

Hi, 

 

I have an issue when I submit a SharePoint detail form through my PowerApp. The scenario works as follow:

- Fill in form

- Submit (onSelect method) SubmitForm(SPFormName)

- (onSuccess) start a flow and passes parameters from the form to the flow 

'FLOWNAME'.Run(PARAMETERS goes here); Navigate(frmSuccessful, ScreenTransition.None)

- It works well when I test it through the studio and the MS Win10 App but I get the following error when I submit using my Iphone App

 

Error: [FLOWNAME.Run failed: the method 'Run' has an invalid value for parameter 'PARAMETER_NAME']

Outcome: The item gets created in SharePoint but the flow does not start.

 

Why will it work on all the different platforms except for the phone app?

 

Any assistance will be appreciated.

5 REPLIES 5
Jeff_Thorpe
Super User
Super User

What type of parameters are being passed? Did you recently make a change to the parameters where the phone app may still have the old version of the app cached?



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Hi Jeff,

 

I pass the SharePoint List Item ID to the flow. I have also logged out of the app and cleared the cache but the issue remain.

 

Regards,

Sorry, I don't think I will be able to help. I try recreating the issue by passing the ID in as a number, text and from a selected item in a gallery into a PowerApps Flow and it worked every time of my iPad mobile app.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Hi Jeff,

 

Does it work on you mobile app? Iphone? 

 

I have seen if I submit 3 forms after each other it starts the flow without any error messages? Does not make sense.

All my test cases were executed on an iPad using a tablet canvas app and they all worked as expected.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (62,657)