cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Impactful Individual
Impactful Individual

OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

So i have created a form in powerapps on a SharePoint list.

I tested everthing in Chrome and everything works.

 

On the form i have OnSuccess: ResetForm(SharePointForm1);Navigate(SuccessMessage, ScreenTransition.CoverRight)

This works fine so it navigates to the SuccessMessage Screen. On the SuccessMessage Scren i have a timer.

 

Timer is set to AutoStart, 3sec

OnTimerEnd: RequestHide();Refresh(HelpDesk); Navigate(FormScreen1, ScreenTransition.CoverRight)

 

This works in chrome, it will close the form when the timer ends. This does not work in Edge.

What is wrong here?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Impactful Individual
Impactful Individual

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

@v-yutliu-msft 

Might have found my issue for Edge.

On the new screen i have OnHidden Reset(Timername)

 

This seems to stop the timer in edge but not in chrome?

 

View solution in original post

7 REPLIES 7
Highlighted
Impactful Individual
Impactful Individual

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

I created a new small form in a new list, use the same code and it works.

I cant remake the form i created because its heavly customised.

 

No matter if i change to simple RequestHide() on timer end this does not work in Edge only in Chrome

Highlighted
Resolver II
Resolver II

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

Anytime I have weird little quirks like this I clear browser cache, you might try that

Highlighted
Impactful Individual
Impactful Individual

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

@strategery Thanks for answering

I have tried to clear all the cache, test on new computers and so on.

It's wierd because it works for me at Home but at work it will not function.

I wonder if this has something with regional settings to do?

 

I ahve same versions of Edge at home and at Work and all users at work have the same issue in Edge only.

Highlighted
Impactful Individual
Impactful Individual

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

New Testing done.

Only Edge is having this issue even on brand new computer nothing touched.

Chrome works fine in edge the countdown timer does nothing or maybe not even starts because there is no refresh or anything going on. I really need help solving this.

Highlighted
Community Support
Community Support

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

Hi @JimmyWork ,

I've tested in my edge but Timer works good.

Please note that : In PowerApps Studio, timers run only in Preview mode("play" button in the top-right corner).

Here's my edge version: Microsoft Edge 44.17763.1.0

Here's my PowerApps version: 3.19084.12

Please update them all to the latest version.

If the problem still exists, I suggest you ask for help here:

https://powerapps.microsoft.com/en-us/support/

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Impactful Individual
Impactful Individual

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

@v-yutliu-msft Thank you

 

I have now tested this and in my form the timer does not start in Edge, it starts in Chrome and runs.

Im just using web.powerapps.com

 

Im not sure why my timer starts in Chrome but not in Edge.

 

Im not sure what you mean with this.

Please note that : In PowerApps Studio, timers run only in Preview mode("play" button in the top-right corner).

Highlighted
Impactful Individual
Impactful Individual

Re: OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

@v-yutliu-msft 

Might have found my issue for Edge.

On the new screen i have OnHidden Reset(Timername)

 

This seems to stop the timer in edge but not in chrome?

 

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (6,190)