cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
JimmyWork
Power Participant
Power Participant

OnTimerEnd does not work in Edge but works in Chrome (Powerapps form)

So i have created a form in powerapps on a SharePoint list.

I tested everthing in Chrome and everything works.

 

On the form i have OnSuccess: ResetForm(SharePointForm1);Navigate(SuccessMessage, ScreenTransition.CoverRight)

This works fine so it navigates to the SuccessMessage Screen. On the SuccessMessage Scren i have a timer.

 

Timer is set to AutoStart, 3sec

OnTimerEnd: RequestHide();Refresh(HelpDesk); Navigate(FormScreen1, ScreenTransition.CoverRight)

 

This works in chrome, it will close the form when the timer ends. This does not work in Edge.

What is wrong here?

1 ACCEPTED SOLUTION

Accepted Solutions

@v-yutliu-msft 

Might have found my issue for Edge.

On the new screen i have OnHidden Reset(Timername)

 

This seems to stop the timer in edge but not in chrome?

 

View solution in original post

7 REPLIES 7
JimmyWork
Power Participant
Power Participant

I created a new small form in a new list, use the same code and it works.

I cant remake the form i created because its heavly customised.

 

No matter if i change to simple RequestHide() on timer end this does not work in Edge only in Chrome

Anytime I have weird little quirks like this I clear browser cache, you might try that

@strategery Thanks for answering

I have tried to clear all the cache, test on new computers and so on.

It's wierd because it works for me at Home but at work it will not function.

I wonder if this has something with regional settings to do?

 

I ahve same versions of Edge at home and at Work and all users at work have the same issue in Edge only.

New Testing done.

Only Edge is having this issue even on brand new computer nothing touched.

Chrome works fine in edge the countdown timer does nothing or maybe not even starts because there is no refresh or anything going on. I really need help solving this.

Hi @JimmyWork ,

I've tested in my edge but Timer works good.

Please note that : In PowerApps Studio, timers run only in Preview mode("play" button in the top-right corner).

Here's my edge version: Microsoft Edge 44.17763.1.0

Here's my PowerApps version: 3.19084.12

Please update them all to the latest version.

If the problem still exists, I suggest you ask for help here:

https://powerapps.microsoft.com/en-us/support/

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-yutliu-msft Thank you

 

I have now tested this and in my form the timer does not start in Edge, it starts in Chrome and runs.

Im just using web.powerapps.com

 

Im not sure why my timer starts in Chrome but not in Edge.

 

Im not sure what you mean with this.

Please note that : In PowerApps Studio, timers run only in Preview mode("play" button in the top-right corner).

@v-yutliu-msft 

Might have found my issue for Edge.

On the new screen i have OnHidden Reset(Timername)

 

This seems to stop the timer in edge but not in chrome?

 

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,172)