cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SkiDK
Level 8

One Powerapp extremely slow in editor mode

Hi everyone,

I'm currently unable to work in one of my Powerapps because it is so slow. It takes about 30seconds before what I type appears in the code box and then it takes a minute or more to recognize it. Adding a control takes also more than a minute.
Saving, closing and opening this app takes ages.
Weird thing is that it's only in one application (which is quite light), and I don't experience this in any other app.

Someone else experiencing this? Of knows what the issue could be?

 

Thanks,

Ski

1 ACCEPTED SOLUTION

Accepted Solutions
SkiDK
Level 8

Re: One Powerapp extremely slow in editor mode

Hey @v-monli-msft 

Thanks for the reply. It seems that I have found the issue.

I was working with a flow, which retrieved a PDF for the pdfViewer by a link in PowerApps. It seems that the issue was when the link was empty. I figured as long as you don't actually call the flow it wouldn't matter. Now on the flow I first check whether the link is empty or not, and only if not empty it will be called. Now the application is much faster again. I honestly have no idea how this causes the slowness. Does it do something when in Design mode even though it is not triggered?

 

 

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: One Powerapp extremely slow in editor mode

Hi @SkiDK ,

 

Could you please share more detailed configuration about this app? What is the data source? How many records are there? Is there any undelegatable formulas included?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
SkiDK
Level 8

Re: One Powerapp extremely slow in editor mode

Hi @v-monli-msft , thanks for your reply,

 

I am connected to a sharepoint library. I have no delegation warnings (and sharepoint lib contains only 300 items).

 

A few days ago I have added a column to the Sharepoint library. Although it shows correct in PowerApps and I have deleted and reconnected the datasource, is it possible it is due to that?

Community Support Team
Community Support Team

Re: One Powerapp extremely slow in editor mode

Hi @SkiDK ,

 

What is the column type? Have you tested with other web browsers? Is this issue only happening while you are in design mode of the app?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
SkiDK
Level 8

Re: One Powerapp extremely slow in editor mode

Hey @v-monli-msft 

Thanks for the reply. It seems that I have found the issue.

I was working with a flow, which retrieved a PDF for the pdfViewer by a link in PowerApps. It seems that the issue was when the link was empty. I figured as long as you don't actually call the flow it wouldn't matter. Now on the flow I first check whether the link is empty or not, and only if not empty it will be called. Now the application is much faster again. I honestly have no idea how this causes the slowness. Does it do something when in Design mode even though it is not triggered?

 

 

View solution in original post

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (4,162)