cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AkshayManke
Continued Contributor
Continued Contributor

Opening Record of Same ID from Current List

Hello All,

 

I know this like complex problem.

 

Below the scenario.

1. I have two SharePoint Lists

2. Both the lists have same columns names.

3. I have added both the lists in to same app.

4. Both the lists have two different galleries and forms.

 

Note

There will be same records created in both the lists with same ID. For example, ID 1 in ListA will have associated detailes in ListB in ID1.

 

Requirement

What i was looking for is: Instead of creating two different galleries, can i create only one gallery and add two buttons in it? 

If I click on 'List A' button then i should get navigated to form for 'List A' and if i click on 'List B' button then i should navigated to form of 'List B'. I think that this can be done using filter and lookup functions but not able to figure it how. Can anyone please help for this?

 

The gallery should look like the below and while clicking on the respective button, user should navigate to the respective screen.

 

Snap.JPG

 

 

 

 

 

 

 

Many Thanks,

Akshay

 

3 ACCEPTED SOLUTIONS

Accepted Solutions
v-bofeng-msft
Community Support
Community Support

Hi @AkshayManke :

I assume there are two lists:

1.PNG2.PNG

I assume your app have there screens:

  • HomeScreen
  • ListAEditScreen
  • ListBEditScreen

I've made a test for your reference:

At HomeScreen

1)Add a Gallery(Gallery1) and set it's items property to:

ListA

2)Add a BackIcon into Gallery1 and set it's OnSelect property to:

Navigate(ListAEditScreen)

3)Add a NextIcon into Gallery1 and set it's OnSelect property to:

 

Navigate(ListBEditScreen)

 

At ListAEditScreen

1)Add an Edit form and set 

DataSource

ListA

Item

Gallery1.Selected

At ListBEditScreen

1)Add an Edit form and set 

DataSource

 

ListB

 

Item

 

LookUp(ListB,ID=Gallery1.Selected.ID)

 

60.gif

Best Regards,

Bof

View solution in original post

Hi @AkshayManke :

LookUp(DevT,ID=Gallery4.Selected.ID)   

Best Regards,

Bof

View solution in original post

AkshayManke
Continued Contributor
Continued Contributor

Hi @v-bofeng-msft ,

 

Your solution is working fine, the issue was with the connection (disconnected with the data source) which was broken which i reconnected. Now the links working exactly as expected. Many Thanks your your help.

 

Thanks,

Akshay

View solution in original post

4 REPLIES 4
v-bofeng-msft
Community Support
Community Support

Hi @AkshayManke :

I assume there are two lists:

1.PNG2.PNG

I assume your app have there screens:

  • HomeScreen
  • ListAEditScreen
  • ListBEditScreen

I've made a test for your reference:

At HomeScreen

1)Add a Gallery(Gallery1) and set it's items property to:

ListA

2)Add a BackIcon into Gallery1 and set it's OnSelect property to:

Navigate(ListAEditScreen)

3)Add a NextIcon into Gallery1 and set it's OnSelect property to:

 

Navigate(ListBEditScreen)

 

At ListAEditScreen

1)Add an Edit form and set 

DataSource

ListA

Item

Gallery1.Selected

At ListBEditScreen

1)Add an Edit form and set 

DataSource

 

ListB

 

Item

 

LookUp(ListB,ID=Gallery1.Selected.ID)

 

60.gif

Best Regards,

Bof

View solution in original post

AkshayManke
Continued Contributor
Continued Contributor

Hi @v-bofeng-msft, I tried following the same steps suggested by you but in my App it is giving some error. Below the snap for your reference. Could you please help me understand where i am going wrong?

 

snip.JPG

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

DevT is the list name and Gallery4 is the gallery. I have added the record in FSCVar hence the code written is (      LookUp(DevT,ID=FSCVar.Selected.ID)    )

 

Could you please help further. Many Thanks.

Hi @AkshayManke :

LookUp(DevT,ID=Gallery4.Selected.ID)   

Best Regards,

Bof

View solution in original post

AkshayManke
Continued Contributor
Continued Contributor

Hi @v-bofeng-msft ,

 

Your solution is working fine, the issue was with the connection (disconnected with the data source) which was broken which i reconnected. Now the links working exactly as expected. Many Thanks your your help.

 

Thanks,

Akshay

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,006)