cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
dschwab1
Regular Visitor

Outlook triggers related to events suddenly broken on September 1st

Issues with event triggers related to Outlook 365 events, all flows were working until September 1.

 

 

  1. "When event is added" trigger starting flow more than once for a single event creation, new behavior. Didn't do that before.
  2. "When event is added" trigger giving wrong data downstream in the flow. Flow is supposed to create another event at the same time on a different calendar, but the Start Time and End Time it gives to the Create Event Action are totally wrong. Went back and checked the output data for the trigger after, but both of these were correct. There are no other actions which took in or created Data and Time data in the flow
  3. "When an event is added, updated or deleted" trigger has the trigger settings stuck. The "split on" setting is turned on, and will not turn off. Also, the trigger condition expression is stuck and cannot be removed. If I change the settings, and then save and leave, when I return the settings were the same as before. Can't fix them.
  4. "When an event is added, updated or deleted" trigger giving different flows with this SAME trigger different information. The deletion of an outlook event in one flow with this trigger is read as "Action type: Deleted." This is correct. Another, separate flow with the same event trigger reads the deletion of the same, exact outlook event "Action type: updated."
  5. "When an event is added, updated or deleted" trigger with conditional expression for "action type: updated" reads ALL outlook events as being updated. Brand new events which are created are read as "Is added: False," and "Is updated: True." That's wrong

 

None of these problems were occurring until September 1st. I've tried using other Outlook connectors and any of them based on events are busted, busted busted. Giving me wrong data, triggering at random. Nothing works.

I am trying to launch a new feature in one of our SharePoint sites in less than a week, and it is wholly dependent on Power Automate Outlook Event Triggers working properly. Please help. Please 😞

1 REPLY 1
mdevaney
Super User
Super User

@dschwab1 

This sounds like a Power Automate question rather than a PowerApps question.  I suggest you post this in the Power Automate Community instead. You’ll get a better response over there

Link to Power Automate Community
https://powerusers.microsoft.com/t5/Get-Help-with-Power-Automate/ct-p/FL_GeneralDiscussions

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,314)