cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Patch not working on first submit

Hi Everyone,

 

I have encountered a strange issue today on an app that was previously working fine.

 

It would seem that when a user on our app presses Submit button, which contains a patch command, they are receiving an error on top of the screen that says Title Required.

 

However, when the press submit a second time, it patches ok.

 

I have tested this app using static data in place of the Title field and the same behaviour exists, the first patch always fails for a user the second one patches.

 

This is been patched to a sharepoint list.

 

Out of ideas on how to tackle this, and as i said at the start, previously this app has been working fine.

Any help would be much appreciated.

 

Ronan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advocate I
Advocate I

Re: Patch not working on first submit

Hi everyone,

 

thanks for the response, but i have found what happened.

 

I had added an extra column to the sharepoint list and also added this into my patch, however there was no default value for the control in powerapps so when i patched the record it failed as there was nothing in the control to patch.

 

It was strange however that it referred to the Title column have the error when it was another column that caused the problem.

 

Anyway all solved now.

 

Lesson here for me is, that it is usually the last thing you changed that broke the system.

 

Ronan

 

View solution in original post

4 REPLIES 4
Highlighted
Super User
Super User

Re: Patch not working on first submit

Please could you share the code used for the Patch if possible? Is this being done on a form that already has a submit somewhere? Have you tried removing the title field from the form and adding it back in again?

 

Thanks,

ManCat


@iAm_ManCat

Please 'Mark as Solution' if someone's post answered your question and always 'Thumbs Up' the posts you like or that helped you!


Thanks!
You and everyone else in the community make it the awesome and welcoming place it is, keep your questions coming and make sure to 'like' anything that makes you 'Appy
Sancho Harker, MVP


Highlighted
Super User
Super User

Re: Patch not working on first submit

Title IS a required column, unless you explicitly turn it off for the list.  To do this:

Open the list in sharepoint.

Click on Settings, then List Settings.

E1.png

Click on Title (which should have a check mark in the Required column like this one does).

E2.png

 

Change "Require that this column contains information" from Yes to No, then click OK.

E3.png

 

This should eliminate the problem of the Patch failing because the required Title field is not getting a value.

Highlighted
Advocate I
Advocate I

Re: Patch not working on first submit

Hi everyone,

 

thanks for the response, but i have found what happened.

 

I had added an extra column to the sharepoint list and also added this into my patch, however there was no default value for the control in powerapps so when i patched the record it failed as there was nothing in the control to patch.

 

It was strange however that it referred to the Title column have the error when it was another column that caused the problem.

 

Anyway all solved now.

 

Lesson here for me is, that it is usually the last thing you changed that broke the system.

 

Ronan

 

View solution in original post

Highlighted
Super User
Super User

Re: Patch not working on first submit


@rockonron wrote:

 it is usually the last thing you changed that broke the system.

 


😂 Yes we've all had those moments, thanks for coming back and letting us know what the issue was 😺


@iAm_ManCat

Please 'Mark as Solution' if someone's post answered your question and always 'Thumbs Up' the posts you like or that helped you!


Thanks!
You and everyone else in the community make it the awesome and welcoming place it is, keep your questions coming and make sure to 'like' anything that makes you 'Appy
Sancho Harker, MVP


Helpful resources

Announcements
Ignite

Microsoft Ignite

This will be a conference that you do not want to miss!

secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,625)