cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Becca51178
Helper II
Helper II

Patching Multiple Items from Collection to Sharepoint List Error

Capture.PNG

 

 

I have a toggle buttons for events that when checked go into a signup form. People can check multiple events at one time. The problem trying to load all of the selected items into a sharepoint. Right now its only letting me upload one at a time. I tried the above solution, but it fails if more than one event leader is selected for an event. Do I have to remove the event leader column to get it to work?

 

Update: Well removing the event leader from the code doesn't work. Is there a way to add it even if there are more than one leaders in charge of an event? I don't want to create a flow just to update that one column

1 ACCEPTED SOLUTION

Accepted Solutions
mdevaney
Super User
Super User

Question for you: can you please check if unique values are being enforced in the SharePoint column for Event Leader? This may be the source of your error. Take a peek in the list settings and let me know.

View solution in original post

7 REPLIES 7
mdevaney
Super User
Super User

Question for you: can you please check if unique values are being enforced in the SharePoint column for Event Leader? This may be the source of your error. Take a peek in the list settings and let me know.

View solution in original post

I had it listed as a required field. If I take away the value completely I can get the items to patch to the sharepoint list. 

Event Leader is tied to a person field. That may be why. I think I will have to create a flow to update the information which isn't really what I wanted to do

@Becca51178
Hmmm, I thought maybe your error was due to SharePoint requiring a unique person for the value. I am not sure you checked that out from your response but I’ll let you know if I have any other theories.

Well I am not seeing that. Powerapps won't let me patch the same person in a collection. I will check Sharepoint again to see if I missed something

No you were absolutely right. I thought I had the enforce unique values turned off. I went and checked. Sure enough they were still on. 

 

Thanks. Everything is working fine now!

@Becca51178 

I am glad to hear its working for you now.  Best of luck with building your app!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,395)