cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
amodtiwari
Helper II
Helper II

Pen input control supplying blank signatures

Hi All,

 

I am facing a strange behaviour with pen input control used in power app new/edit form. i have used a flow to generate signature image files in a library and flow is called on submit button in power app. flow is working fine for all cases and generating image files during test over browser and mobiles/tablets. 

 

Now a strange case found, user is using tablet and signed under pen input and left tablet ideal for 10-15 mins ideal and then submitted form. 

issue- signature files are processing blank. 

flow is running and creating image files with no signatures. 

 

1. Is there any limitation of pen input to loose drawing with app. 

    please refer below link point 4, if its a cause for this. 

Common issues and resolutions for Power Apps - Power Apps | Microsoft Docs

2. Is there any possibility of drawing reset or color change as image file background.

 

please suggest.

 

Thanks

Amod

2 REPLIES 2
Pstork1
Dual Super User III
Dual Super User III

I would assume this is caused by the session timing out and the fact that the image is stored in the browser cache.  The best fix is probably to include a timer in the app that prompts the user to save their work within a particular period of time, perhaps 10 minutes.  Start the timer in the OnSelect event of the Pen Input control.  When the timer expires have it reset the pen input control.  This will require the user to sign and commit the form within that period of time.  Reset the PenInput to blank using Reset(PenInputControlName).  You can also change the background color using the fill property.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
amodtiwari
Helper II
Helper II

Hi All,

 

In regards above discussion, end users are using tablet devices and getting signatures as blank for few items. most of them are generating correct signatures. i am not sure what is root cause now. 

 

Is there any specific behavior of power app with tablets please. 

This is online entry and code is processed on submit button click. code is something like below-

Set(varJson, JSON(p1.Image,JSONFormat.IncludeBinaryData));
Set(varJson, Mid(varJson,24, Len(varJson)-24));
SignatureCapture.Run(varJson);SubmitForm(EditForm1)

 

am i doing something wrong that is causing probably blank signatures at first attempt or like that. 

 

please help me. 

 

Thanks

amod

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,504)