cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KOM_4410
Resolver II
Resolver II

People picker in form - weird bug

Hi all,

I'm experiencing a problem with the people pickers in PowerApps that has been driving me crazy for a while, I hope some can help me.

 

I have a Sharepoint list with several columns, few of them People type column. I have a PowerApp connected to this list and I included here a form that includes some of this People type column from the SharePoint list. Using this method I can use the data card in the app to select people from my Active Directory, which is exactly what I want and it works well.

 

The app works fine all the time until I have to edit something. For some reason, when I open the app in edit mode, all this people picker break! The error message on the red bubble reads "The data source supplied to the function is invalid" which is really weird because everything else works fine.

 

To fix I just click on the red bubble with the error, which takes me to the items property of the data card and all I do is to delete one letter of the source in the formula bar, select it again and that fix the problem!!!!! 

 

it is really annoying because I use the same method in all my apps and I'm experiencing the same problem with all of them, so every time I edit my app for anything I have to check all the people picker and correct them. I'm showing the issue with the gif below. I will really appreciate if anyone can help.

 

Cheers

 

u5s2nHf25x.gif

1 ACCEPTED SOLUTION

Accepted Solutions
v-siky-msft
Community Support
Community Support

Hi @KOM_4410 ,

 

What an annoying experience, but I am not sure if this is a bug, because i haven't met this issue.

Some suggestions, you can collect all Office365 users to the collection at the start of app, set it to Combo box's Items, and then modify the Update property to submit the selected users to SPlist Person column.

In this way, it can speed up the search fucntion of combo box, and avoid choice() error you mentioned.

Following is the steps:

1. collect all Office365Users to the collection, set the following formula to OnStart of app.

ClearCollect(coluser,Office365Users.SearchUser({searchTerm:"",top:500}));

2. set Items property of Combo box(that data card) as below.

coluser

3. set update property of datacard as below.

{Claims:"i:0#.f|membership|" & DataCardValue1.Selected.UserPrincipalName,Department:"",DisplayName: DataCardValue1.Selected.DisplayName,Email: DataCardValue1.Selected.UserPrincipalName,JobTitle:"",Picture:""}

Hope this can help.

Best regards,

Sik

View solution in original post

4 REPLIES 4
v-siky-msft
Community Support
Community Support

Hi @KOM_4410 ,

 

What an annoying experience, but I am not sure if this is a bug, because i haven't met this issue.

Some suggestions, you can collect all Office365 users to the collection at the start of app, set it to Combo box's Items, and then modify the Update property to submit the selected users to SPlist Person column.

In this way, it can speed up the search fucntion of combo box, and avoid choice() error you mentioned.

Following is the steps:

1. collect all Office365Users to the collection, set the following formula to OnStart of app.

ClearCollect(coluser,Office365Users.SearchUser({searchTerm:"",top:500}));

2. set Items property of Combo box(that data card) as below.

coluser

3. set update property of datacard as below.

{Claims:"i:0#.f|membership|" & DataCardValue1.Selected.UserPrincipalName,Department:"",DisplayName: DataCardValue1.Selected.DisplayName,Email: DataCardValue1.Selected.UserPrincipalName,JobTitle:"",Picture:""}

Hope this can help.

Best regards,

Sik

View solution in original post

Thanks for that @v-siky-msft . I think that workaround solves the problem. I'm not collecting the users because they are too many in my org but I'm using the Office365.SearchUsers function on the combo box and that works just as good.

Just one more question. On Step 3, do you know how that expression needs to be if I selected more than one person in the combo box of step 2?

 

Thanks

AnkitShah55
Advocate III
Advocate III

@v-siky-msft Please resolve this problem. One of our apps is facing exactly same problem.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (48,137)