cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Super User
Super User

Player and IDE Preview NOT Matching

Hello,

I'm having a serious problem here. An app is working CORRECTLY in the IDE Preview, but showing errors on the iPhone and in the browser Player. 

- Error 1:  "An error occurred on the server..."

    - There are certainly NOT 300 simultaneous sessions on this database.

    - THIS IS ONLY OCCURRING ON MOBILE PHONE! Opening the app in the browser Player does not result in this error!

    - Any ideas on this one?

image.png

- Error 2: The IDE Preview does NOT match the iPhone nor browser Player.

- In the Player (iPhone and Browser), the date shown is not rendering correctly (red block covering date).

image.png

 

- This date drives the color of the Gallery Items below it.

- Session ID: 52f65696-d98a-44b7-8d41-07cca344fddd; PowerApps 3.18114.16

- Choosing the same record using the IDE Preview; the date IS rendered correctly and the Gallery Items show up as they should.

image.png

- Session ID: 714bfb7f-2152-42a8-8f72-8b731c7bf9b4; PowerApps 3.18114.26

Additional Details:

- Azure SQL backend

- App worked great in my tenant

- App is not working well after being exported from my tenant (United States) and imported into customers tenant (South Africa)

- App Settings Turned On: 

    - Delayed Load

    - Use Non-blocking OnStart Rule

    - Improved App Rendering

Thank you

5 REPLIES 5
Highlighted
Impactful Individual
Impactful Individual

Re: Player and IDE Preview NOT Matching

Well it looks like you might be doing a lot of looping / lookups on total readings there per item could be triggering that error.

I’ve had odd issues using SQL backend on my app I made for doing readings where it would work fine in preview but I would be missing data and it just wouldn’t render in play mode. The work around for that was I had to create galleries in my app that used the columns I used elsewhere in the app and I would change to where the items returned was always 0 records and it was hidden. It’s almost as if the fields had to be bind to a control ahead of time to render. I dunno. Just a hunch cause I had issues till I created those galleries and used my fields in them even though they returned no records and were not visible I couldn’t reference fields from a connected data source table till it was attached to that hidden gallery somewhere in the app.
Highlighted
Super User
Super User

Re: Player and IDE Preview NOT Matching

Thank you very much for the reply.

Has anyone else seen this type of behavior before? Any thoughts on this issue or @cwebb365's comments?

Is there a pattern (Lookup, Filter, etc.) that can cause issues with Galleries using Azure SQL as Items?

Highlighted
Impactful Individual
Impactful Individual

Re: Player and IDE Preview NOT Matching

Well I think depending how your pulling that number in your gallery it’s probably making a connection for each. So your better approach to solve that one would Probably bring your data local filtered down to the data that would be used to a collection. Then run your gallery lookups against it so it’s not going out to the database so much.

The date issue might be separate and related to what I’m talking about with a reference to a field not bound to a control. Is the date just completely missing in play mode vs designer?
Highlighted
Impactful Individual
Impactful Individual

Re: Player and IDE Preview NOT Matching

Hey Seadude, take a look at this article, came across it the other day, and will explain the looping (using lookup in gallery) and how it makes calls for each, and how you can get around it by collecting your data locally first into collections, then pointing your gallery and embeded lookup to use the local collection you create. 

 

Hope this helps. 

 

https://powerapps.microsoft.com/en-us/blog/performance-considerations-with-powerapps/

 

 

Highlighted
Anonymous
Not applicable

Re: Player and IDE Preview NOT Matching

Hi @seadude thank you for posting this thread and I'm sorry to hear you're experiencing this issue. Can you review the latest reply from @cwebb365 and advise if it helps your situation?

 

@Anonymous

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Users online (3,418)