cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Derpette
Frequent Visitor

PopUp doesn't appear in the right layer order (Z-order) for some users

My app contains a screen with a gallery, which can be sorted and filtered with some controls. These controls are grouped together as a popup, which appears when someone presses the sort/filter button (updatecontext a variable which controls the visible property). This group is the top group in the tree view/Z-order.

 

For most users the intended popup with the sort/filter menu appears when they press the button. But for some users the popup is transparent and the sort/filter controls are shown in the same layer as the gallery text (see attached  screenshot). 

 

Does anyone have an idea what could cause this problem and how I can solve it? 

1 ACCEPTED SOLUTION

Accepted Solutions
WarrenBelz
Super User
Super User

Hi @Derpette ,

This is a known issue with certain monitor and font magnification (I get it on UHD Samsung monitors at 150% font size). It is not consistent, however is always on the right side of the screen. If you change font size, or shift the control further left, it goes away. I think this is a PC graphics issue more than a Power Apps one.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

View solution in original post

3 REPLIES 3
WarrenBelz
Super User
Super User

Hi @Derpette ,

This is a known issue with certain monitor and font magnification (I get it on UHD Samsung monitors at 150% font size). It is not consistent, however is always on the right side of the screen. If you change font size, or shift the control further left, it goes away. I think this is a PC graphics issue more than a Power Apps one.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Thanks a lot! Dragging the menu to the left solved the issue.

One more question: does this issue to your knowledge not happen on the left most side of the screen?

Hi @Derpette ,

I have always fixed this by moving the offending control further left on the screen (it has never failed in the left half for me). I have a lot of apps and controls running on these monitors and it seems to happen at random but quite infrequent times.

 

Helpful resources

Announcements
Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (2,626)