cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Possible Bug: SharePoint Picture Library images not visible on Tablet

Hi,

 

I am currently building an app where I am using Flow to save images to a SharePoint online Picture Library and then I get those images and display them in a gallery in the app.

 

I was testing on my computer (Windows 10) with the web editor (ver. 2.0.692) and it all works perfectly, the images are being shown in the Gallery. Then I tested with a Windows tablet (Windows 8.1) with the PowerApp studio (ver. 2.0.690) installed and when I open the app the Gallery is empty and no picture is shown.

I have also tested with my Android phone with the PowerApp studio (ver. 2.0.681) and the images still don't show.

 

Is this something related with the platform? Why are the images being display on the PC and not on any other device? Can please someone investigate this? This is a really urgent requirement that I am working on.

 

Thanks

 

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

So for anyone looking for a solution to this, I have finally manged to find it thanks to @paul_culmsee!

 

Here's the workaround he created to retrieve the images from a SharePoint Picture Library:

http://www.cleverworkarounds.com/2017/09/29/its-not-a-proxy-its-a-floxy-a-way-to-display-sharepoint-...

and I have just tested it and it works amazingly! 

 

 

View solution in original post

11 REPLIES 11
v-yamao-msft
Community Support
Community Support

Hi MelindaK,

 

Do you have PowerApps studio for Windows on your PC?


Have you tried the app on your PC to see if the images will be displayed on the gallery?


According to your description, I created a PictureGallery on my SharePoint site.


On the Web studio(2.0.692), create an app based on this list, set the Image with ‘{Link}’, the images are displayed well on the gallery.

3.PNG


Save the app then open the app on other devices, including on my PC(Windows 10), PowerApps version on my PC is 2.0.690, however, the images are blank.

4.PNG


Do you get the same issue with me?


If you are getting the same issue on PC, please feel free post back. I will help confirm it on my side.

 

Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @v-yamao-msft

 

I can confirm I get the same on the PowerApps Studio (ver. 2.0.690) - the pictures are not showing.
However, if I open the app on the browser (outside the editor) the pictures are being shown.

 

App in PowerApps StudioApp in PowerApps StudioApp in WebApp in Web

Thanks

Anonymous
Not applicable

Hi @v-yamao-msft

 

3 weeks later a new PowerApps version (2.0.702) and issue still exists. 

 

Have you been able to re-create it on your side? Is there any investigation conducted for this problem?

 

Thanks

Anonymous
Not applicable

I've done some more testing on this and it looks like on the tablet images don't show at all, no matter what environment I use:

 

images.png

@v-yamao-msft can you confirm this on your side? Is it a bug? 

 

 

However, on another app where I take the images from an Azure blob storage they are being displayed on all devices/environments. It seems it's related with the SharePoint Online Picture Library.

Anonymous
Not applicable

So for anyone looking for a solution to this, I have finally manged to find it thanks to @paul_culmsee!

 

Here's the workaround he created to retrieve the images from a SharePoint Picture Library:

http://www.cleverworkarounds.com/2017/09/29/its-not-a-proxy-its-a-floxy-a-way-to-display-sharepoint-...

and I have just tested it and it works amazingly! 

 

 

View solution in original post

@Anonymous Hey can u tell me how did u connect to the pictures library.

I followed the process in the blog you provided but its not wworking for me.

Its giving error at HTTPS:// --> as invalid name.

Thanks

 

MasterOffice365
Advocate II
Advocate II

 
Any image stored in SPO, rendered within a PowerApps app in any resolution as you so desire.
 

  

38 MB Image

  • Thumbnail as small as: 3-5 Kb

  • 2500px rendition: 200 Kb

Office365Master
Advocate V
Advocate V

 
 
Any image stored in SPO, rendered within a PowerApps app in any resolution as you so desire.
 

  

38 MB Image

  • Thumbnail as small as: 3-5 Kb

  • 2500px rendition: 200 Kb

Anonymous
Not applicable

Hi @Anonymous ,

 

Really good point, I followed it too, but the flow's trigger was not Powerapps.

With Flow, i would suggest a better (and more recent) solution from Brian Edwards @brianedwards

SharePoint Images Powered Up In PowerApps
https://www.myconsult.co.za/residue/brians-blog/

 

The only issue with Flows is if your application will be widely used. For example, I have this huge international client (over 10 000 users). And they did not buy more Flow credit, so the entire organization has only 2000 execution allowed by each Flow.

 

With a List with Attachments, at first i tried ThisItem.AbsoluteUri, but as everyone had the same problem of displaying the images on studio but not on the app (mobile nor desktop), I had to come with a workaround :
The workaround is pretty simple : 
For Image Column, just get the Thisitem.TheNameOfyourImageColumn


For Attachments column : Create a ImageGallery child of your ItemsGallery.

ImageGallery.items = First(First(Filter(YourItemList,ThisItem.ID = ID)).'{Attachments}')

Add an Image Control to this Gallery.

MyItemImage.Image = ThisItem.Value

This Value gets something like 

appres://datasources/YourItemList/table/e3aa2c1a-0137-4a7c-ab24-fd9a907db316/rows/7/reference/https:%2F%2Feurope-001.azure-apim.net%2Fapim%2Fsharepointonline%2Fshared-sharepointonl-f5c8d3ff-b9f6-48b9-badd-52ca6ba45e36%2Fdatasets%2Fhttps%25253A%25252F%25252FYourTenant.sharepoint.com%25252Fsites%25252FYourSite%2Ftables%2Fe3aa2c1a-0137-4a7c-ab24-fd9a907db316%2Fitems%2F7%2Fattachments%2F%25252fLists%25252fYourItemlist%25252fAttachments%25252f7%25252fYourAttachmentFileName.jpg%2F$value

I don't know why it works so, maybe someone from the PowerApps / Sharepoint team could explain ?

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (73,932)