cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
beyondthebox
Regular Visitor

Possible Gallery Bug?

Let say I create Gallery 1 in Container 1 and put 6 controls in the gallery. When I cut the gallery from Container 1 and paste into Container 2, the X & Y of all the controls is set to 0, and the width is set to 1. BTW, none of the controls make reference to the parents height or width, or its X or Y. They all have fixed values so PowerApps has no reason to reset them.

 

Has anyone else noticed this and what is the process for Microsoft to investigate and fix?

3 REPLIES 3
iAm_ManCat
Super User
Super User

Would not expect them to look into a low priority item like this tbh.

 

What I will say is that you can kinda work around this as the items are attempting to add 30 to each value to offset them, which if your gallery is small enough will result in an error so it instead sets them to zero and 1, but you can mostly stop it doing that by making the value a formula instead of a static value:

 

Width = 36

Nope, now:

Width =  0 + 36

 

That should stop it overwriting most values, there are still some exceptions - could you give that a try going forward? I've learnt to do this by default eventually to save time in the long run

@iAm_ManCat


Please 'Mark as Solution' if someone's post answered your question and always 'Thumbs Up' the posts you like or that helped you!


Thanks!
You and everyone else in the community make it the awesome and welcoming place it is, keep your questions coming and make sure to 'like' anything that makes you 'Appy
Sancho Harker, MVP


beyondthebox
Regular Visitor

The problem with Microsoft is every thing is low priority and many many things don't get fixed. I will give you suggestion a try but this is what Microsoft is counting on. Why should they fix something if there is a work-around. The low code approach should not be mired in crazy work-arounds.

Look, I don't disagree with you, I think there should be an easy way for standard users to submit bugs like this, but there isn't. I am only trying to help you as I have run into the same issue with copying controls all over the place and having them appear in the wrong location or with incorrect values.

@iAm_ManCat


Please 'Mark as Solution' if someone's post answered your question and always 'Thumbs Up' the posts you like or that helped you!


Thanks!
You and everyone else in the community make it the awesome and welcoming place it is, keep your questions coming and make sure to 'like' anything that makes you 'Appy
Sancho Harker, MVP


Helpful resources

Announcements
October Events

Mark Your Calendars

So many events that are happening this month - don't miss out!

Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Top Solution Authors
Top Kudoed Authors
Users online (3,900)