cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Posting Collections to On-Premise SQL - Replicating data

Hey, Not having an issue posting from the App to SQL, the issue is that if i have 3 items in the collection it's pasting 3 items in SQL table, but all as the last entry in the Collection. The Collection is grabbing all the data from a Gallery and apending it correct in the app, but when submitted its just the wrong data.

 

This is the code from the Gallery + add new:

Patch(
    SampleCollection,
    ThisItem,
    {
        SampleQtyCol: Value(Qty.Text),
        SampleQtyDescCol: QtyDesc.Text,
        SampleDateCol: Date.SelectedDate,
        SampleTypeCol: Type.Text,
        SampleTestCol: Test.Text,
        SampleReceivedCol: Received.Value
    }
);
Collect(
    SampleCollection,
    {
        SampleQtyCol: 0,
        SampleQtyDescCol: "",
        SampleDateCol: Today(),
        SampleTypeCol: "",
        SampleTestCol: "",
        SampleReceivedCol: false
    }
)

This is the code from OnSuccess.

ForAll(
    SampleCollection,
    If(
        !IsBlank(Qty),
        Patch(
            '[dbo].[SampleData]',
            Defaults('[dbo].[SampleData]'),
            {
                SampleDate: Date.SelectedDate,
                SampleQty: Value(Qty.Text),
                SampleQtyDesc: QtyDesc.Text,
                SampleType: Type.Text,
                SampleTest: Test.Text,
                SampleRecevied: Received.Value,
                SSFMaster: Form2.LastSubmit.SSFID
            }
        )
    )
)

I have attached the SQL Screenshoot.

Any help would be appreciated

2 REPLIES 2
Highlighted
Anonymous
Not applicable

Re: Posting Collections to On-Premise SQL - Replicating data

adding in @GregLi to help with this question

Highlighted
Anonymous
Not applicable

Re: Posting Collections to On-Premise SQL - Replicating data

@Cranny In looking at the code, it appears it is the order of operations that are causing the problem. First you create the collection, then you clear it before you submit it. 

Could you try editing the code so that the collection is cleared after the data has been submitted to SQL? Please let us know if this helps?

PS. You reference form 2 in your code to submit to SQL, where is form 2 in this scenerio? 

Thank you for your patience @Anonymous

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (6,710)