cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Cranny
Level: Powered On

Posting Collections to On-Premise SQL - Replicating data

Hey, Not having an issue posting from the App to SQL, the issue is that if i have 3 items in the collection it's pasting 3 items in SQL table, but all as the last entry in the Collection. The Collection is grabbing all the data from a Gallery and apending it correct in the app, but when submitted its just the wrong data.

 

This is the code from the Gallery + add new:

Patch(
    SampleCollection,
    ThisItem,
    {
        SampleQtyCol: Value(Qty.Text),
        SampleQtyDescCol: QtyDesc.Text,
        SampleDateCol: Date.SelectedDate,
        SampleTypeCol: Type.Text,
        SampleTestCol: Test.Text,
        SampleReceivedCol: Received.Value
    }
);
Collect(
    SampleCollection,
    {
        SampleQtyCol: 0,
        SampleQtyDescCol: "",
        SampleDateCol: Today(),
        SampleTypeCol: "",
        SampleTestCol: "",
        SampleReceivedCol: false
    }
)

This is the code from OnSuccess.

ForAll(
    SampleCollection,
    If(
        !IsBlank(Qty),
        Patch(
            '[dbo].[SampleData]',
            Defaults('[dbo].[SampleData]'),
            {
                SampleDate: Date.SelectedDate,
                SampleQty: Value(Qty.Text),
                SampleQtyDesc: QtyDesc.Text,
                SampleType: Type.Text,
                SampleTest: Test.Text,
                SampleRecevied: Received.Value,
                SSFMaster: Form2.LastSubmit.SSFID
            }
        )
    )
)

I have attached the SQL Screenshoot.

Any help would be appreciated

2 REPLIES 2
Highlighted
TopShelf-MSFT
Level 10

Re: Posting Collections to On-Premise SQL - Replicating data

adding in @GregLi to help with this question

TopShelf-MSFT
Level 10

Re: Posting Collections to On-Premise SQL - Replicating data

@Cranny In looking at the code, it appears it is the order of operations that are causing the problem. First you create the collection, then you clear it before you submit it. 

Could you try editing the code so that the collection is cleared after the data has been submitted to SQL? Please let us know if this helps?

PS. You reference form 2 in your code to submit to SQL, where is form 2 in this scenerio? 

Thank you for your patience @TopShelf-MSFT

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,440)