cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
arnonel
Helper IV
Helper IV

[Potential Bug] CDM lookups

If I have the following entities:

  • Car
    • Name:
    • Interior Color: Lookup to Color entity
    • exterior Color: Lookup to Color entity
  • Color
    • Name (used for lookups above)

 

When I open "Car" in Excel, and put "Red" for interior color, it puts "Red" for exterior color too. Instead of letting me choose 2 seperate colors. 

 

Assume this is a bug?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Hi Arnonel,

 

We have reproduced this issue. It can be seen in both the Excel Add-in and in a PowerApps app, so the problem appears to be in the data layer. We are investigating more. Thanks for bringing it to our attention!

 

- Chris

 

View solution in original post

11 REPLIES 11
v-yamao-msft
Community Support
Community Support

Hi Arnonel,
                                  
How did you create your custom entities? To reproduce this issue, could you provide your steps?

 

I created two entities Car and Color.
>About Color entity, I opened this entity in Excel and filled “Red” and “Blue” in the Excel, then Published it.
>About Car entity, I added two Custom fields(Interior Color and Exterior Color) and set these two entities to Lookup to Color entity. When I opened this entity in Excel, I can choose separate colors in each column.

 

Please make sure you create proper Custom entities and Custom fields. This article about building a relationship between entities in the Common Data Model could be a reference for you.

 

The article link is:
https://powerapps.microsoft.com/en-us/tutorials/data-platform-entity-lookup/


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Seriously? 

 

This feels like a canned respone.

 

I have tried to keep it as simple as possible.

 

Can you at least tell me if this is an expected behaviour or a bug?

 

(You dont really want me to say: "I click 'create entity', I create a lookup, etc" do you? From below it should be fairly self explanetory.

 

 

Hi Arnonel,

 

We have reproduced this issue. It can be seen in both the Excel Add-in and in a PowerApps app, so the problem appears to be in the data layer. We are investigating more. Thanks for bringing it to our attention!

 

- Chris

 

View solution in original post

No worries, thank you for looking into it. Thought I was going crazy.

 

ETA for resolution?

No ETA yet since we just started looking at it. We'll update this thread when we know more.

Thanks

Any update please?

Apparently this bug didn't get prioritized by one of our teams. I'm following up...

This bug is now assigned and hopefully will be fixed in the next couple of weeks. Thanks for checking in on it! 🙂

Hi Arnonel,

 

We are working on a fix for this.

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,866)